Freedome won't open after installing on Mac OS X Yosemite

I downloaded the latest Freedome version for Mac (I'm on Yosemite). I dragged the icon to Applications. When I click on th e file to open the app, it states that it needs Elevated Privileges and asks for my admin password (which I know is correct) on the next screen. I enter the password, and then nothing happens.  I'm assuming that it is crashing, but no message is displayed.  The icon is not in the menu bar or dock.

 

I have uninstalled the app and all of the support files that I can find and emptied the trash.  Then rebooted the Mac.  I then re-downloaded the file and installed again.  Same result. It just exits. 

 

Can someone please assist?

 

Thanks.

 

Ben

 

Comments

  • Ben
    Ben Posts: 2,641 F-Secure Product Expert

    Hello BenD,

     

     

    In order to make sure all traces of the previous version are gone, please proceed to uninstall as follows:

    -Remove Freedome from /Applications. 

    - Delete the folders "/Library/Application Support/F-Secure/FSFreedome" and "~/Library/Application Support/F-Secure/FSFreedome" 

    -Remove "Your F-Secure Freedome Key" from your login keychain (it's in Passwords category).

    -Reinstall the latest version available here.

     

    Let us know should you have problems.

  • BenD
    BenD Posts: 5

    Hi Ben,

     

    Did everything you suggested.  Re-installed with download from your link.  Same result.  Another user (Joerg) had the exact same issue here.  He was assisted by Laksh.  Not sure if it was ever resolved, but it may be worth checking into.

     

    Thanks for your help.

     

    Ben

  • BenD
    BenD Posts: 5

    I guess no one will be helping with this issue.  I'm moving on to another VPN solution that works (and has support that works).  Thanks for nothing.   Goodbye.

This discussion has been closed.