Virtual location does not work

I just installed Freedome into my Win 7x64 laptop and it seemed to install OK. I tried to test it, but the results so far are bad. I want a VPN to allow me to surf USA shopping sites that block their traffic to foreign locations. I connected Freedome through three USA Freedome locations (Eastern, South, and West), but the shopping sites I want to see fail to connect at all. I get only a DNS_Probe_Finished_Bad_Config error message. Another site that I can connect to through Freedome provides only partial information with other parts blocked. Is there some magic I need to do to make Freedome work correctly? I also have SecurityKiss VPN and it worked OK until I installed Freedome. Now I cannot connect to SecurityKiss even with Freedome turned off. Any suggestions? Thanks!

Comments

  • Two quick corrections. First, Freedome does not work at all for me. When it is on, I cannot open any web page. I guess it is possible that this country blocks all traffic to the Freedome VPN, but I do not know how to test that. Second, SecurityKiss does work OK. My earlier tests must have been during a SecurityKiss service outtage. If anyone can suggest a way to make Freedome work, I would be happy to try it. Thanks!

  • LakshLaksh Posts: 4,442 Community Manager

    Hi Jim-1,

     

    May I know which country you are currently in and are you having the issue in connecting from all the locations?

     

    Do you see any error message when you try to turn on Freedome?

  • Thanks for the reply. I am on assignment in Saudi Arabia now. Although SecurityKiss does work for me, at least sometimes, I did see a link in SecurityKiss that opened a page that said it was blocked by Saudi Arabia.

     

    There were no error messages when I installed, or when I tried to use, F-Secure. My only indication that there was a problem was that I could not connect to any web sites when F-Secure was on. Perhaps coincidentally, in the hours after I installed F-Secure, I began to have connection problems (with F-Secure off) which appeared to get progressively worse over time. I thought the problems were from my router, even though I had no similar problems befor I installed F-Secure. Since the problems were becoming painfully frequent, I guessed that they might have something to do with the F-Secure installation. I uninstalled F-Secure and then did a system restore to a point I created immediately before I installed F-Secure. I have had zero connection problems since I removed F-Secure from my computer. That limited experience does not prove that the F-Secure installation caused problems for me, but it is sufficient to discourage me from installing F-Secure again.

This discussion has been closed.