Browser won't connection using Freedome beta under OSX Yosemite

Since updating Freedome to the beta (I'm unable to see the version number) on my Mac running Yosemite (10.10.5), I'm unable to connect to any sites when Freedome is switched-on. Chrome just shows "Resolving host" for several seconds before giving the error "ERR_NAME_NOT_RESOLVED". There is also a similar experience in other browsers. I've tried against multiple locations and the experience is the same. I have an active subscription, but have not tried reinstalling as I'm already at my subscription limit. Thanks.


  • davida
    davida Posts: 2 New Member

    I think I've got this sorted now by disabling DNSCrypt and rebooting...looks like Freedome doesn't play nicely with it...

  • [Deleted User]
    [Deleted User] Posts: 0 Former F-Secure Employee

    Hi @davida,


    I have moved your post to the Beta and Technology Preview board since this was regarding Freedome Beta.


    I hope your issue is resolved now!

  • NotDavid
    NotDavid Posts: 1 New Member
    I had the same problem (OS X 10.11)

    The problem is, when you have set your own DNS servers (in my case, DNS-Crypt), Freedome doesn't change them, but it does apparently block them.

    I believe the Tunnelblick VPN client handle's this very well, it changes the DNS server on connection, and reverts them to the old settings when disconnected. And it also has an option to "not set DNS severs".
This discussion has been closed.