F-Secure 2016 blocks downloads

Hi,

 

during the last few day I set up my new PC (Clean installation of Windows 10 x64). For this I had to download the newest versions of some applications. Before doing this I installed the newest build of F-Secure IS (Should be the 2016 version).

 

F-Secure 16.0


Common Component Framework 2.44 build 135

CCF CUIF 10.04 build 275
CCF DAAS2 1.10 build 565
CCF Guts2 2.01 build 676
CCF Upstream 2.02 build 265
CCF Diagnostics 9.00 build 342
CCF Scanning 1.67 build 117.607
CCF Network 1.04 build 100
CCF Reputation 2.0 build 1337

 

On some sites F-Secure blocked the downloads of the files.

For example on:

www.getthunderbird.com (Thunderbird Emial Client)

www.acronis.de (also  on .com) (Acronis Trueimage)

www.garmin.de (Garmin Express)

www.kobobooks.com (Kobodesktop)

 

Symptoms:

Download didn't start even waiting for some minutes.

 

It took me a while but then I finally found out that the F-Secure IS option that blocks downloading of malicious files even when firewall is disabled blocks these downloads. (Don't know the exact name in english because I'm using the german version of F-Secure IS). Disabling this option solved the problem for me (Downloads started immediately).

I never experienced any issues of this kind in the 2015 version so I gess it was introduced with the 2016 version.

 

Can anyone confirm this?

 

mHaZweiO

Comments

  • LakshLaksh Posts: 4,444 Community Manager

    Hi mHaZwei0,

     

    Was this an upgrade of the FSIS or did you install it freshly on your computer?

     

    May I know what type of files were downloaded from these websites and could you give us an example link of the download? If the setting 'Do not allow applications to download harmful files' is enabled, you can prevent any application from downloading harmful files that may harm your computer. 

     

    May be a screenshot of the blocked downloads in your browser and if any error message seen which also help to troubleshoot further.

  • Hi Laksh,

     

    it was a fresh install on a new PC.

    One example from www.getthunderbird.com is thunderbird_setup_38.2.0.exe.

    The corresponding link is: https://download.mozilla.org/?product=thunderbird-38.2.0&os=win&lang=en-GB

     

    I tried to download the files with different browsers (Opera, Firefox, Edge, IE11) but the result was always the same when the option 'Do not allow applications to download harmful files' was enabled. The browsers tried to establish the connection to the site but this didn't work. If I remember correctly the downloads should mostly come from some Content delivery networks (CDN).

    This is an example of the status bar of Firefox from today:

    Firefox Status bar.PNG

     

    While waiting the timer is counting up but there's no download progress. There's also no (error) message from FSIS! That's the reason why it took me a while to find out the reason for the issue.

     

    When I disable the 'Do not allow applications to download harmful files' option the download starts instantly. So I'm pretty sure that FSIS is the culprit.

     

    For your information: There's also HitmanPro.Alert installed on this machine. One of my first ideas was to disable the protection for Opera which a mainly use for browsing but that didn't make any difference.

     

    Regards,

     

    mHaZwei0

  • LakshLaksh Posts: 4,444 Community Manager

    Hi mHaZwei0,

     

    As our Experts tried to reproduce the issue, we were unable to reproduce it and the download worked fine for the thunderbird website on our end.

     

    We might need futher information regarding this issue, like is there any 3rd party software being used to download the files or how the download process exactly works (like clicking on the link which contains the installer and it does not work), etc. In this case, it is recommended to open a support ticket with your query and details so that our support can look at the issue and check further since the issue could not be reproduced at hand.

  • Hi Laksh,

     

    thanks for the update. I did some further tests and it seems that there's a conflict between FSIS and HitmanPro Alert. When HitmanPro Alert is enabled the downloads get blocked when at the same time the  'Do not allow applications to download harmful files' option is enabled in FSIS. I'm going to write a message in the HitmanPro Alert support forum.

     

    Thanks for helping.

     

    mHaZwei0

     

     

  • LakshLaksh Posts: 4,444 Community Manager

    Hi mHaZwei0,

     

    Thanks for updating and glad to know that it has been resolved now. Smiley Happy

     

    Since you mentioned the issue was caused due to a conflict, I would recommend to have only FSIS on your computer. The reason being, it might lead to a conflict if there are more AV programs installed on your computer.

  • I have experienced the same issues without any conflicting software.

     

    New Laptop.

    Windows 10 Pro 64 bit

    Installed latest F-Secure Internet Security (FSIS).

    Then I went to install via download the rest of the new software and had a repeated problem, in every browser, only fixed by turning off the application download filter.

     

    He is a list of links that would not work until FSIS Advanced Network Settings, 'Do not allow applications to download harmful files'.

     

    http://support.logitech.com/product/wireless-gaming-headset-g930#download  - Attempting to download ends in a blocked connection.

     

    http://www.skype.com/en/download-skype/skype-for-computer/  - After choosing the download option the page will load but the connection to the setup file is blocked.

     

    I have others including pages on the Microsoft site but these should be enough to determine the problem.  So in order to setup my new machine I have had to disable the tool that is designed to protect it. Perhaps a default list of safe sites with the ability for a user to add new ones should be provided. I appreciate such a procedure may add to the opening time of a page but this would only occur in pages with download links.

     

  • Yet another mainline site is being blocked as harmful by FSIS.

     

    HP Support's driver download pages.

     

    Leading page - http://support.hp.com/us-en/drivers/selfservice/HP-ENVY-4500-e-All-in-One-Printer-series/5304875/model/5368521

     

    Download Link - http://ftp.hp.com/pub/softlib/software12/COL47762/mp-115701-6/EN4500_198.exe

     

    As this is happening so often on the windows 10 machines I've been forced to disable the feature.  On all the Win 7 Pro machines this was never an issue. 

  • JouniJouni Posts: 135 F-Secure Product Expert

    Hi Grazer,

     

    The links seem to be clean, so they should not be blocked by F-Secure as harmful. Also, we could not reproduce this problem.

     

    Mainly it sounds like the problem could be similar to the original poster, so probably it is some sort of a conflict causing this.

     

    In this case please open a support ticket with F-Secure diagnostic file(fsdiag) included, so that we can further investigate the problem.

     

    Here you can open a support request:

    https://www.f-secure.com/en/web/home_global/support/support-request

  • I have received no help to date that I am aware of. For now I keep the protection turned off making it entirely pointless. 

     

    I have purchased F-Secure since the 90's when I had it installed in a UK bank I was working for.  Unfortunately the company seems to have joined the same path as other more invasive and less agile technologies in it's drive to be a popular consumer product. This increased 'integration' and more assumptive user shell code will always cause issues with new platform releases however I have tried three competing software offerings without the same problem on this platform.

     

    Whatever the problem is, having to deliberately disable a key part of the product functionality on Windows 10 devices is a serious concern. I should point out that there is no problem on Windows 7 32 or 64. What happens when MS forces out Windows 10 to those millions of Windows 7 Home users?

     

     

  • I would like to report the same exact problem. About a week ago I installed Windows 7 Home Premium clean on a new motherboard and only installed the drivers of the motherboard and GPU before installing F-Secure SAFE. At the beginning it disrupted even the Windows Update, only beginning to work properly after uninstalling, downloading the updates, and reinstalling the software. But even now it continues to prevent the download of almost any .exe-files and .zip-files even from the most reliable sources, such as asus.com. The .exe-files fail to download entirely and .zip-files stop at 99% without completing. I have been able to get around it by disabling the protection during downloads, but needless to say that this isn't a permanent solution.

     

    There are no other anti-virus programs installed on that computer and none of my other devices with F-Secure SAFE have shown this kind of problem, so I have to assume that it's either a conflict with the drivers and/or apps that came with the motherboard (Asus Maximus VIII Ranger), or an issue that the current version of SAFE has with freshly installed Windows systems.

    ScootCoot
  • tasistasis Posts: 2

    I have this same problem. I bought a new Asus G751JT laptop with Windows 10 and installed F-Secure Safe. The laptop had McAfee AV pre-installed, but I uninstalled it completely before installing FS Safe. Now I am unable to download any EXE files, two examples that I tried below.

     

    I have tried with MS Edge and Firefox browsers. If I uncheck "Do not allow applications to download harmful files"- option from FS Safe Firewall settings, downloading works perfectly. Is it an intended feature, that all EXE-files are considered harmful?

     

    I'm using:

    F-Secure SAFE 16.1
    Antivirus 14.150 build 101
    DeepGuard 5.0 build 580
    E-mail Filtering 1.02 build 20399
    Management Agent 8.30 build 43239
    User Interface 17.00 build 246
    Virus Protection 11.00 build 21434

  • LakshLaksh Posts: 4,444 Community Manager

    Hi @tasis and @Lightice,

     

    We have checked on the links shared above and the ratings are safe. As @Jouni has mentioned in his reply here, please open a support request in order to check further.

This discussion has been closed.