After upgrade to ios 9 cannot connect anymore to Freedome?

Confused Posts: 2 Observer

How to solve this ? 


  • jorelikins
    jorelikins Posts: 6 New Member
    I had the same problem

    not sure all these steps are required by worked for me

    1. delete the Freedome app
    2. go to settings / general / reset
    3. select 'reset network settings' and follow the prompts
    4. once your phone has rebooted, reinstall the Freedome app, which will also reinstall VPN config

    as I said this worked for me and hopefully will for you to


    No need to reset network settings. I fixed mine this way:

    1. Remove Freedome profile

    2. Uninstall Freedome

    3. Reinstall Freedome from appstore

    4. Open freedome and start -> will create new profile

    5. It works

  • jorelikins
    jorelikins Posts: 6 New Member
    cool thanks bfish...good to know if it happens again Smiley Happy
  • And what about the registration code ?
  • Ben
    Ben Posts: 2,020 F-Secure Product Expert

    Hello all,


    For those who are having trouble connecting after upgrade to iOS 9, simply going to Settings and tapping "Remove VPN configurations" should do the trick.

  • Ben
    Ben Posts: 2,020 F-Secure Product Expert

    We also have now this article regarding that problem.

  • I am new to this and can write a new post. Help I also have problems. Pmiffy. 

  • kennybe
    kennybe Posts: 26 Explorer
    Hi, yes this problem is solved but, there is a big problem whith the performance after upgrade to IOS9. Performance impacts reduced from c:a 80 Mbit/s to 5 Mbit/s.
    This is measured in my wireless network with the IPhone 6.
  • Ben
    Ben Posts: 2,020 F-Secure Product Expert

    Hello kennybe,


    On which virtual location do you get such performance?


    @Pmiffy did you already tried the above mentioned solutions?

  • kennybe
    kennybe Posts: 26 Explorer
    My vitual location is Stockholm. I live in Sweden.
    On my wire-connected PC (Windows 10) where I also use Freedome
    My speed is 15 mBit/S (Stockholm). With location Espoo My speed is 89 mBit/s.
    On my IPhone 6 and location Espoo my speed was 32 mBit/s.

    How do you explain this?

    To @Pmiffy: the first thing did, delete the vpn-config. Uninstall and install again.

    Regards kennybe
  • amowbry
    amowbry Posts: 2 New Member

    I've tried the steps outlined in this article, but after the last step listed, I just get a box that reads, "Touch ID for 'Settings'," with only a "Cancel" option. What do I do then?

  • Tapsa
    Tapsa Posts: 82 F-Secure Employee

    This "Touch ID" dialog comes from the operating system. It prompts for fingerprint scanning ("Touch ID" is the Apple term for fingerprint), as the fingerprint scanning is enabled on the device. If it would be disabled, it would prompt for a pin code instead.

  • amowbry
    amowbry Posts: 2 New Member
    Thanks! It turns out that, even if you have Touch ID turned off, you have to delete any fingerprints saved on your iPhone. I think it's an unnecessary and annoying hiccup, but that's what threw me off.
  • Johan29
    Johan29 Posts: 2 New Member

    I'm still struggling to use Freedome after upgrading to IOS 9.0.1. Everything works fine when I'm using Safari, but when I try to use whatsapp it just says "connecting..." and there is no VPN sign on the screen. I can use Whatsapp with a little trick when opening the iPhone -> first open Safari and that activates the Freedome and then go to Whatsapp but it is quite frustrating doing it on and on.


    I have tried all the tricks listed here, but none of them have worked with Whatsapp.

  • eskimojo
    eskimojo Posts: 4 New Member

    I have exactly the same problem as Johan29 is describing. I have done all the possible tricks that I've found from the forum - like resetting and even removing and reinstalling both whatsapp and freedome. Reinstalling whatsapp only removed all my chat history, but so far nothing has helped the actual problem.


    The other trick besides opening safari is to open freedome. It also activates the vpn.


    I would really appreciate the application to work. Have bought it for a multiple devices... and I'm getting pretty upset!

  • Johan29
    Johan29 Posts: 2 New Member

    Any fix on the issue? I still can't properly use Freedome and won't be continuing my subscription. I'm running latest Ios 9 on Iphone 5s.

  • Laksh
    Laksh Posts: 4,224 Former F-Secure Employee

    Hi @Johan29,


    Tapsa has already replied to this issue in the other post with Freedome iOS problem with Whatsapp. Please find his reply here.

This discussion has been closed.
Product & Pricing Info