Won't Connect - Freedome F-Secure VPN For Mac

Hello I use Freedome for VPN security. On my Mac, the application just had an update, and now it won't connect anymore. I tried restarting as well as changing the location. Whenever I click on, it says "connecting...connecting" but never does, then gives up. How can I fix this?


  • I, too just got prompted to download and automatically update Freedome for Mac. The update downloaded but did not install automatically as the message suggested it would. I therefore manually installed it but, like the OP, the new version could not connect. I tried a few different servers with no success. Fortunately I was able to roll back to the older version and connect without problem.

    I am running OSX 10.9.5 and was upgrading from Freedome 1.0.1712.0 to 1.0.1842.0.


  • Laksh
    Laksh Posts: 4,443 Former F-Secure Employee

    Hi @Ramanujan88 and @accuor,


    Does this connection issue show any kind of error message as well?


    Ramanujan88, could you please share your OS version as well?


  • I don't get any error message. The animated circle on the UI and in the menu bar continue to run. The text inside the circle says 'Connecting...' but the connection is never made.

  • My OS version is 10.10.5

  • How can I roll back to my older version? Do I uninstall freedome and download it again on the F-secure website?

  • I don't recommend that you uninstall Freedome as this will most likely lose your subscription. I was able to roll back because the update did not happen automatically so I still had the old version on my hard disk.

  • OK, It looks like mine is working now. The update had installed itself as Freedome2.app (because I opted to keep the old version on disk). When I renamed the new version to Freedome.app and ran it, it connected fine. I changed the name of the app back to Freedome2.app again and it still ran fine.

    I'm not sure, therefore,  whether the name change played in any part in getting it to work but at least it's working again now. 

  • Devo
    Devo Posts: 2

    I have the same issue a month ago and about a week ago my friend found out there were two Freedome files in my Application (perhaps due to updating. He deleted one of them then it came back to work. Then I got a notification again. So I tried to clean the Application again, but still it wasn't working. I decided to uninstall and install it again. I put everything in the trash and it has been emptied by a friend. So I only have one Freedome 22.46.48 modified 31 August and it's as big as  43,3MB. What can I do. It will always try establishing connection but it failed every time. I was using 6-months free susbscription code and have 60 days left. 


    I hope anybody can help! Thank you!

  • Laksh
    Laksh Posts: 4,443 Former F-Secure Employee

    Hi Devo,


    May I know what is the current version of Freedome on your Mac? Is the Freedome 22.46.48 modified 31 August present in your trash bin?

  • Devo
    Devo Posts: 2

    Since my trash bin was emptied. This is the only file I have and installed on my mac. I can't figure the issue and totally feel lost. Thank you for your help!

  • I tried lots of suggestions, but nothing work. So I deleted my freedome, and than reinstalled. It worked! I'm sure not that's not antidote for everything situation, but those who haven't yet give it a try. The first time it didn't work for me, but I had forgotten to empty my recycle bin, so that may have been the problem.

This discussion has been closed.
Product & Pricing Info