help needed after using F-Secure Booster

On renewing my license for F-Secure, I was offered Booster. I purchased both and ran Booster. That created lots of problems, that are still not solved. Customer support refers to the forum for help, so I hope this does a better job.

Booster is in the meantime uninstalled. A system recovery does not seem to go anywhere before the Booster running. I have reinstalled MS Office and broadband at home.

Following issues still exist:

mobile broadband does not work

printer seems to be installed (can print), but control panel does nor show any printer

safe taking away of usb-stick is returning to control panel staring to load but just running without anything happening

control panel does not give any info on network connection

samsung software manager does not come to life

 

Customer support send me fdial program and I returned the file it creates, but nothing promises on escalating the issue to technical people has only resulted in a response to give my key for getting my money back and ask the forum for help.

 

What do do now to get my computer working as before????

 

Samsung & windows 7 home

Comments

  • LakshLaksh Posts: 4,444 Community Manager

    Hi @gicka,

     

    I have moved your post to the relevant board as this is regarding Booster product.

  • LakshLaksh Posts: 4,444 Community Manager

    Hi gicka,

     

    Regarding your queries, could you please try the following options?

    1. When you installed Booster, what was the issue which lead you to uninstall the Booster? Since Booster is uninstalled now, did you have these issues even when Booster was installed?

     

    2. Can you try to search in your Control Panel for Printer and see if the 'Devices and Printers' are listed? If yes, can you view your devices or printers?

     

    3. Could you brief us more on the USB issue? Have you tried to click on unload/eject the USB drive from your computer and does it show you that the device has been safely unloaded?

     

    4. Did you have the system restore enabled before Booster was installed?

  • 1. Uninstalled as suggested by customer service after email about the problems. Did not see the problems during the very short period Booster was installed. The problems arose immedialty after installing Booster.

    2. It takes very long time for the control panel/printers to open and then shows nothing.

    3. It goes to the control panel, tugging long and then nothing happens. The previuos pop-up response that it is save to detach the USB does not come up.

    4. Not htat I was aware off. there was no suggestion to do so on the installation.

     

    regards,

     

    Gicka

  • LakshLaksh Posts: 4,444 Community Manager

    Hi Gicka,

     

    I am checking with our team for more details on your issue. I will get back to you once I have further information.

This discussion has been closed.