F-Secure AV for Mac - Security Cloud Malfunction Error

New install on Mac OSX Yosemite, all okay except for the above "Security Cloud Malfuntion" error.  Machine has working internet, no proxi set.

Anybody have any suggestions?

 

Answers

  • BenBen Posts: 2,640

    Hello Trevor,

     

    Could you double check that you have access to our servers mentioned in this article.

  • Just purchased F-Secure. 3 new installs-uninstalls - continue to get Security cloud malfunction - Your Computer Is Not Protected

     

    New system restore from backup - still same messages - any help greatly appreciated

     

     

  • BenBen Posts: 2,640

    Hello Philster37,

     

    Do you use a Mac or a PC?

     

    Did you review the article mentioned above?

  • Hi, thanks for your reply.

     

    I am using a Mac.

     

    Can you explain how I configure the proxy server - if that's what is required?

    I tried selectingWeb Proxy  HTTP and SEcure Web Proxy HTTPS and then entering one of the network ranges given in the article - but I then lost internet access until I removed this change.

     

    Thanks

  • Hi, I would be grateful for a reply.

    In the meantime I found this article:

    https://community.f-secure.com/t5/Security/Configuring-a-http-proxy-for-F/td-p/6119

     

    This explains how to configure the proxy server.

     

    Unfortunately, the code is writen incorrectly. I know nothing about this so I have had to teach myself how to error-check the code. There is a redundant space in the first line, but getting to the second gives:

     

    open -t /tmp/fsaua_config
    The file /tmp/fsaua_config does not exist.

     

    This suggests that something is missing from the software downloaded from the F-Secure server. I could be wrong. Any help gratefully received.

     

    Thanks in advance

  • of course . . .right . . .the fsaua_config file has now been removed.

     

    I can't belive how complex this s becoming . . .

  • I have just run the F-Secure support tool (found in Applications/F-Secure) which generated this report:


    Running sw_vers
    Copying software version info files.
    Running package verification for com.f-secure.* pkgs
    Copying crash/hang/panic reports
    sudo: /var/db/sudo owned by uid 501, should be uid 0

     

    Anyone have any ideas - to be frank, I find it a bit strange to be debugging a new piece of software as soon as I install it.

     

    I guess Linux is open soure and F-Secure expects the community to fix it . . (that was a joke)

    Any pointers how to fix this would be appreciated

  • BenBen Posts: 2,640

    Hello Philster37,

     

    The information provided on this article is old and not anymore valid.

     

    If you have a proxy, it should work just by entering the appropriate settings in the OS X system preference. In some case you might need to reboot so that they are taken into use.

     

    However if you are not using any proxy, then you could try running the cloud diagnostic. 

    To do so on your installation, Alt+click on the menu bar F-Secure icon and select "Cloud Diagnostics"

    The diagnostics should be shown in a new browser window.

  • Has this issue been solved? As I have just had this issue come up on my iMac and it has interfered with web browsing. Also in says it fails when trying to instal the web browsing installer.

     

  • GzusGzus Posts: 1

    Also getting "Your computer is not protected - (x) Security Cloud malfunction" on Mac (OS X 10.11.3). Running Cloud diagnostics gives in Safari: "Failed to open page. Safari can't open the page "localhost:49164/diag/dump/" because Safari can't connect to the server localhost.""

     

    What should I try next?!

     

     

  • Gzus, great name - I feel the same!

    Same problem and still no idea how to fix it - the suggested fixes lead to another problem with another suggested fix...as you say, Gzus!

    Has anyone actually resolved this?

    Please...........

  • TapsuccaTapsucca Posts: 501

    Hi and thank you for your message,

     

    I would advice you to take contact directly to our phone- or chat-support, where we can investigate the issue more deeply.

     

    https://www.f-secure.com/en/web/home_global/support

  • Jan13Jan13 Posts: 1

    same problem on my system (sierra 10.12.6).

    cause: name resolution for host "localhost" did not work

    resolution: adding "localhost" entry  to /etc/hosts

     

    diag and fixing steps:

    1) tried cloud diagnostics (Alt+click on the menu bar F-Secure icon). result in browser window: "could not open..."

    2) verified running process on local machine which listens on port 49155:

    a) open terminal window

    b) sudo lsof -n -i4TCP:49155 | grep LISTEN

    result showed running process: OrspServi 129 daemon   13u  IPv4 0x864f8122f194df4b      0t0  TCP 127.0.0.1:49155 (LISTEN) => OK

    3) verified name resultion

    a) ping localhost inside terminal windows

    result: not found

    4) checked hosts file

    a) sudo cat /etc/hosts

    result: no entry with ip 127.0.0.1 and name localhost

    5) added entry to hosts file

    a) sudo nano /etc/hosts

    b) added line 127.0.0.1<space><tab>localhost<cr>

    c) verified name resultion again with "ping localhost" => worked

     

    => cloud function was working again.

     

  • M1kahM1kah Posts: 3

    I got Security Cloud Malfunction problem that was slightly different.

     

    I noticed that Security Cloud Diagnostics tried to open diagnostics page using HTTPS. OrspService was running OK but it just was not reachable.

     

    I fixed my issue with the following steps:

     

    1. I opened ~/Library/Cookies/HSTS.plist with xcode

    2. I removed entry for localhost and saved the file

    3. Restarted

     

    It should be OK also to delete ~/Library/Cookies/HSTS.plist file and restart if editing is not possible.

This discussion has been closed.