Safe installation fails with Internet Security already on system

I have used F-Secure Internet Security on my Computers for years now and never had a problem.  My subscription was due and I noticed I could get F-Secure Safe for the same update price.


The problem has started when trying to install it, as I downloaded the installer and have both run it as is and as administrator and every time it get to 65+% saying 'removing previous software' (or something simular) and then stops saying 'Installation Failed'


I have tried a number of times and it does the same each time and I'm wondering if I should uninstall Internet Security myself first and then try again.  The trouble is I do not like having to uninstall security software and leave myself wide open to all the malware around.  Does anyone have any idea's on this, as my subscription for Internet Security run out tomorrow and I would like this fix ASAP.




Acer Aspire 5750z laptop with Windows 7 installed, but thinking of upgrading to  Windows 10 if everything looks good, safe and big error free.


  • Chameni
    Chameni Posts: 234 F-Secure Employee

    Hi Ish68,

    It looks like the previous uninstallation didn't go through completely and that might cause conflict during the new installation. It is recommended to remove the program manually from Control Panel and if it still fails you can try to run the standalone uninstaller from F-secure. You can refer below link for the steps:

    Uninstallation steps :

    Installation steps for F-Secure SAFE :


    Thank you.

  • Hi there,


    I am having the exact same issue as the post that you replied to. I have the same laptop also. Acer aspire 5750. F Secure was working fine up until I switched to Windows 10 but not since I switched back.


    The person who has the same problem as me has not switched to Windows 10 yet but is having the same issue. The programme tries to install but does not complet at around 65+ % and I get the message, Installation Failed. I uninstalled with no isse but am unable to reintall. I even wasted a liscence thinking that would help.


    Not sure what else to do.


    Thanks, Susan

  • Chameni
    Chameni Posts: 234 F-Secure Employee

    Hi Susan,


    Have you tried to run the uninstallation tool from F-Secure as the above post? This will help to do a clean uninstallation by removing any left over files which belongs to the old installation and once that is done, you can try to reinstall it from F-Secure Safe Portal. Please try the provided steps and revert back if you need further assistance on this.


    Thank You

  • Hi there,


    yes, I did this to remove the installed programme and it does not exist in my programme list anymore.  That's why I can't understand what the issue is.


    I have tried to reinstall over 20 times now and I get the same response every time. Installation failed.


    If F Secure is not going to protect me while online then I need to protect myself with another provider.  I have 6 months left on mt subscription and would need to have that refunded.  Do you know how I would go about that also?


    Thank you again for your time and help with this.



  • Laksh
    Laksh Posts: 4,224 Former F-Secure Employee

    Hello Susan,


    If you have already tried the Uninstallation tool with the above mentioned steps but the issue persists, I would recommend you to either open a support ticket or chat with our support personnel.



  • _CyberGhosT_
    _CyberGhosT_ Posts: 18 Observer

    Try downloading Ccleaner its free, but only download it from its publisher "Piriform"

    It will clean up any leftover drivers and make sure to reboot before attempting to reinstall.. PeAcE

  • Thank you,


    I have just raised a ticket and hope to have this resolved soon.


    All the best, Susan

This discussion has been closed.
Pricing & Product Info