Freedome connects and after few secs disconnects

I installed Windows 10 and Freedome worked fine for one day. The next day, Freedome started to connect, then after few seconds disconnected, then connected again, then disconnects again after few seconds, etc. etc.  Freedome worked without and issue in Windows 8.1. I tried to disable firewall with no effect. I have tried different servers with the same results. I have uninstalled and then reinstalled Freedome. No success.

 

I'm using normal cable broadband via cable modem. I have several other devices on the same network, but I'm not using freedome in those.

 

 

Comments

  • LakshLaksh Posts: 4,442 Community Manager

    Hi Djkaapula,

     

    Seems like your post is similar to the other post mentioned here with the Freedome reconnecting in Windows 10.

     

    This was the latest reply on the post:

    Thank you for the diagnostics report. We have identified this problem and it will be fixed in the next version. We need to do some testing with our fix first before the release, but we’ll try to make this version available as soon as possible.

     

     

This discussion has been closed.