Freedome won't turn on

I was running Freedome with no problems when I was invited to join the beta program. I run the uninstall tool and installed the beta version. The beta version installed and I was able to register it. However, now Freedome will not turn on. After a short time it issues an error message and invites me to get a diagnostic. I then uninstalled the beta and installed a new downloaded version of Freedome. It turns out that this downloaded version is exactly the same, v1715 as the beta version. The downloaded and beta versions act identically and refuse to turn ON.

How do I go back to the original version which worked?

 

My platform is Windows 10. And, the original version of Freedome that ran was installed in Windows 8.1 and carried over to Windows 10 with the upgrade from 8.1 to 10.

Comments

  • LakshLaksh Posts: 4,444 Community Manager

    Hi RoyK,

     

    Based on your post, does the Freedome tries to connect and disconnects after a short while? Or does it not turn on at all when you try to turn it on?

     

    Did you try the uninstall and reinstall after the upgrade to Win 10?

  • RoyKRoyK Posts: 5

    Freedome simply refuses to turn on.

    I have uninstalled and reinstalled several times.

     

  • LakshLaksh Posts: 4,444 Community Manager

    Hi RoyK,

     

    In this case, could you try to check the option under Settings > "Freedome turns on protection automatically when it starts"? Once done, try to restart the computer and check if the Freedome is turning on automatically or not?

  • RoyKRoyK Posts: 5

    Freedome won't turn on after a restart.

     

    I reinstalled a new trial version of Freedome. This new version will not give me a trial as it simply says it is inactive from the beginning and immediately asks for a registration code. Obviously it won't turn on. After I enter my subscription code it says I have 365 days left and is active. However, it still won't turn on either manually or after a restart.

     

    I recently installed Freedome on my laptop and I noticed that the installation took a small fraction of the time it took on my desktop. My desktop is a faster computer yet the installation takes maybe 4 times longer on the desktop. There must be some vestige of Freedome on my desktop because it does not recognize the free trial. However, I can't find that vestige as I have used the f-secure removal tool and even JV16 Power Tools to remove everything of Freedome that is visible.

  • RoyKRoyK Posts: 5
    Freedome keeps issuing an error message every minute or so. It says "something went wrong". I have to uninstall it again as I can't accept getting an error message every minue.
  • LakshLaksh Posts: 4,444 Community Manager

    Hi RoyK,

     

    I will message you via PM for further discussion on this issue.

  • RoyKRoyK Posts: 5
    I have replied to your message.
  • Did you get it solved?

     

    I have the same issue, since I installed the recommened update!!

     

    I tried now to uninstall & reinstall, but I simple can't turn it ON..

     

    Thank you,

     

    Martin

     

    RandomPerson
  • f2f2 Posts: 1

    I have the same problem. What is the solution?

    RandomPerson
  • My Freedome does not turn itself on no matter what. It was going fine 'till today and still goes ok for Android. But when running on Windows 8.1 it seems to be plain dead. The big Protection ON-OFF buttom is useless.

  • pfgnpfgn Posts: 1

    This has happened to me too, after the last Windows 10 major update on 11/14/2015.  Settings are set to autostart, I get message "something has happened, we are sorry" I have uninstalled, rebooted, and reinstalled and get the same results.

     

    Also, during reinstall, before reinstall was finished, I get "Freedome driver cannot install, please reboot" 

  •  I wonder if someone got some help from the support Team. Up 'till now I got no answer. And the issue continues.

  • No, nothing ... poor support. I even send a PM to one of the Community Managers, but no response!!

     

    Seems to be a clear issue with Win 10 TH2 1511... 

     

  • Indeed. I also tried to contact someone by PM. No answer...

     I don't think it's about W10: I downgraded my PC back to 8.1 a month or so ago and now I've this problem. I have no idea about what to do. And I'd like to know if they are going to extend our subscription or refund for the days without support.

  • Still not sure. I have the same release running smooth running on one Win7/64bit and a Win8.1. All have the same recommened update from freedome. On the 8.1 system I skipped the last patchday patches... after I had an issue with a Win7 KB & Office/Outlook. 

     

    I honestly doubt that we have any chance to get a refund.

  • LakshLaksh Posts: 4,444 Community Manager

    Hello Everyone,

     

    Apologies for the delayed response on this issue. We do have reports and are aware about this issue; our Freedome team is investigating further. However, in order to troubleshoot further, please open a support ticket from here and provide all the details of the issue.

  • Laksh,

     

    Please be aware tha my issue has nothing to do with Windos 10. I downgraded my PC back to Windows 8.1 before the problem.

    Please, be also aware that the hyperlink you gave leads to nowhere: "Woops!
    404: Page not found"

  • LakshLaksh Posts: 4,444 Community Manager

    Hi @Chivalry,

     

    I tried again and I was able to open the link without any issues. Please open a support request here for your issue: https://www.f-secure.com/en/web/home_global/support/support-request

     

  • I am getting the same issue on Windows 10 (ticket raised).

    I'm a little surprised after so many months this has not yet been resolved.

     

    Could you please post the status of this, in my opinion, critical defect.

  • rapidmoverapidmove Posts: 9

    Hi there,

     

    for me, the problem was solved (Nov 2015) with the V 1.0.2352.0

     

    Currently I am running V 1.4.3038.0 without any issue.

     

     

  • Im running 1.5.3284.0  on Windows 10 and it won't connect.

  • rapidmoverapidmove Posts: 9

    try to submit an official support request via:

     

    https://www.f-secure.com/en/web/home_global/support/support-request

     

    I did the same and got the reply after some days, that a new version was available and that solved the problem.

     

    Good luck!

     

This discussion has been closed.