Freedome Bluescreen NDIS.sys on every start

I have installed Freedome on my PC but every time I try to activate it the computer shut down with a bluescreen and a hint to NDIS.SYS with a DRIVER_IRQL_NOT_LESS_OR_EQUAL error.


Anyone with the same problem or any suggestions how to fix the problem?


The LAN and WLAN drivers are from ATHEROS and they are both up to date.


2015-08-18 14.24.54.jpeg


  • Laksh
    Laksh Posts: 4,443 Former F-Secure Employee

    Hi Magisthan,


    What is the OS of your computer in which you are trying to install the Freedome product?


    In the meantime, I would also check on the blue screen issue and get back to you.

  • Laksh
    Laksh Posts: 4,443 Former F-Secure Employee

    Hi Magisthan,


    I will PM you for further details regarding this post.

  • Hello Laksh,


    got your message and will send a diag file. Can´t send the diag file because my file is 26,7 MB.

  • I have send the DIAG file into the FTP incoming folder


    The name is:

  • Hello,


    I had the same problem. I tried to activate Freedome twice and every time it ended up by a bluescreen.

    It was a crash dump so I checked my memory with the software MemTest and I hadn't any error.


    In the end I used the software WhoCrashed. It found that the crash have been caused by GlassWire. So I removed it and now it's working fine.


    I don't know if this will help you but if others have the same problem, it worked for me.



This discussion has been closed.
Product & Pricing Info