Problem with license activation [Anti-virus Mac]

Hi. I purchased an anti-virus key yesterday to activate the mac os version of the product.
When I enter the license key and press the activate button, I get the following message: "There was an error connecting to the service. Please try again later". I tried several times but the activation keeps failing.
Should I just wait and try again later or is there some problem with my system?
I also tried to remove and reinstall the product but the result is still the same.
Thanks in advance for any reply and please excuse any language errors (English is not my first language).

Tabrez

Accepted Answer

Comments

  • SimonSimon Posts: 2,653 Superuser

    I'm not familiar with Macs, but assuming your network connection is working OK, would it be possible to try a different browser to the one you're getting the error with?  Or, could it possibly be a Firewall issue?  Just guessing, but it might give you some ideas of things to look at.  dunno.gif

    Ukko
  • slucianslucian Posts: 14

    The activation procedure is managed by the anti-virus itself, not by a browser (I think it's a binary named licensetool, but I may be wrong). I've already tried to disable the firewall, but that didn't solve the problem.

  • UkkoUkko Posts: 3,198 Superuser

    Hello,

     

    Sorry for my reply.

     

    Does you mean that you have just F-Secure AV (for Mac) solution. Or it's part of F-Secure SAFE?

    If it's part of F-Secure SAFE... maybe there just stuck about web-portal.

     

    If it's just F-Secure AV (for Mac) as one solution. Maybe if your installer have license-key under name. Maybe you can to remove it.. and will try to add this by hands.. during prompt about (installation step)?

    SORRY/added later: so.. if you already type it by hand (does it's copy-action? or indeed type it? maybe source comes with invisible characters?); And maybe you can try to add license-key for installer and will try again (probably it work for Windows like that, but maybe for Mac.. there can be another design;  such as "installername_license-key_.dmg"?)

     

    Sorry again for my reply and not nice English.

  • slucianslucian Posts: 14

    It's just F-Secure anti-virus (for Mac) as one solution (not F-Secure SAFE).

    What do you mean when you say: "[...] maybe you can try to add license-key for installer and will try again [...] for Mac there can be another design;  such as: installername_license-key_.dmg"?

    I can only insert the subscription key (20 digits code) in the field that you can see in the next figure (the license key is obviously different from that shown in the image):

     

    image1.png

     

    So here when I press the "Set" button I get the following message:

     

    image2.png

  • UkkoUkko Posts: 3,198 Superuser

    Hello,

     

    I not sure.. that it's can be same between Windows and Mac platform.

     

    But with Windows installer can be next variants (as example);

     

    -> fsprotectioninstaller.exe - during installation will be prompt for input license-key (or if F-Secure SAFE >> portal webpage).

     

    -> fsprotectionInstaller_LICENSE-KEY-CODE_.exe - will be auto-handle (?) for license key activation.

     

    Such as.. if with Mac platform.. you have installer (?) as .dmg-file?!

    And it's can be with name like "fsprotectioninstaller.dmg".... maybe you can to modify it for : "fsprotectioninstaller_TWENTY-DIGITS-CODE_.dmg".

    Potentially.. it's can be as trigger for autohandle your license-key during installation.

     

    What if.. some of "mistakes" can be ignored by current steps.

     

    Also.. if you  copied license-key from letter or something same!? Can it's be that there just comes mistake under license-key? Or maybe you forger to add something else? Maybe license-key have some more characters? Some kind of re-check... what there can be.

     

    Anyway... just because I can not to re-check it with your platform... of course.. my words.. just as "suggestions" about "what I can to try to re-check before normal response by F-Secure". because probably.. tomorrow.. when F-Secure people comes to community they can to re-check your license-key (as support-ticket) and re-check if it's server-based trouble.. or license-key can be invalid (and they can to give for you new one).

     

    With F-Secure SAFE installer comes with ".mpkg"-extension (not .dmg - I just not really friendly with Mac) . It's mean... there can be same design about license key.. just installer-name and extension can be of course with another variants (name) and (.mpkg).

     

    Sorry for my reply again and for not nice English.

  • SimonSimon Posts: 2,653 Superuser

    I had a similar issue once, but when I manually typed in the license key, instead of copying and pasting, it was accepted.  Might just be worth a try, and also check that you're not typing a zero instead of a letter O (or vice versa), as that is another easy mistake to make. 

     

    If nothing seems to be working, I can only suggest you open a Support Ticket with a licensing issue, in case there's some sort of problem with the license itself.

    Ukko
  • slucianslucian Posts: 14

    I tried all your suggestions, but nothing seems to work. In fact, the problem seems to be not in the license code, but in the program itself.

    When I try a different license key (even a completely random one) I get the same error message (and not a "wrong license key" message as should be) as if the validation script could not reach the activation server to check the validity of the key.

    Also, modify the installer name (from "F-Secure-Anti-Virus-for-Mac.mpkg" to "F-Secure-Anti-Virus-for-Mac_XXXX-XXXX-XXXX-XXXX-XXXX_.mpkg" or similar - where XXXX-XXXX-XXXX-XXXX-XXXX is my license key) doesn't  change at all the installation process: the software always requires you to manually add the key in the preferences panel.

    Anyway, thanks for your help. I'll wait until tomorrow to see if something changes and if not I'll open a Support Ticket as suggested from Simon.

  • Geo1Geo1 Posts: 3

    I've got the same problem with my Mac, spent hours with support who at one point took over my computer remotely. They were unable to solve the problem even then. It installs OK and seems to work but no matter what is done it will not accept the activation code. 

  • Sueh20Sueh20 Posts: 4
    I'm having similar problems my safari won't let me load my F-Secure on my iPad whys this happening anyone else having problems it seems wrong when we are paying for it to
  • slucianslucian Posts: 14

    Problem solved. Thanks Master_Yoda.

  • Geo1Geo1 Posts: 3

    @Master_Yoda wrote:

    Hello Everyone,

     

    Would you mind trying out the key validation steps again? There was a glitch in our system and we managed to fix it. Should there be a problem, please reply and I will look forward to assist you guys! Smiley Happy


    Well, well, well, at last. I spent hours on your Help line and even gave over my machine to remote access. I was told that because I was running OSX 10.11 Beta on my Mac, an upgrade from Yosamite, that 10.11 was not supported. I found this hard to believe as F-Secure installed on the machine without any problems at all. It only refused to accept the Authorization Key. After a while it became obvious to me that the Registration Process was at fault. This has caused me quite a lot of bother, I've had to install a different Anti Virus to cover myself until you fixed the problem. F-Secure is now working. Not a good start to your software it has to be said.

  • Master_YodaMaster_Yoda Posts: 4 Former F-Secure Employee

    Well, My apologies for the inconvenience caused as it took an awful lot of time to discover where was the problem to begin. I believe I might've said that to the tech support guys that OSX 10.11 is not OFFICIALLY supported though and I'm sorry for that too.

    I'm glad now it works well on your system and should there be anything, please bring it up in this thread or call our tech support too.

    Thanks for staying with us even during hard times :) Appreciate it a lot!

  • Geo1Geo1 Posts: 3

    OK, alls well that ends well!! 😀😀😀

This discussion has been closed.