Freedome not working with Windows 10 - reinstall doesn't work

Hi there,

I installed Win 10 Pro on a new hard drive. I also installed F-Secure Freedome. (the setup seems to work normal)

However when i start Freedome it only shows for 3 seconds in the symbol bar and then its gone again. Nothing happening.

Reinstalling (with deinstalling and also with simply installing again doesnt help.

 

greetings

webProtected

Comments

  • Is there no solution? Windows 10 not supported??

  • LakshLaksh Posts: 4,444 Community Manager

    Hi WebProtected,

     

    Sorry for the late reply.

    Yes, Freedome supports Windows 10. However, regarding your issue, are you able to see the icon in the task bar?

     

    Have you tried to start the program using the task bar icon or from the desktop icon? Does it start? Or does it show any kind of error message during the start up?

  • Hi Laksh,

    i see the Icon in the task bar for 2 seconds than it disappears. (it seems the program crashes without an error poppig up)

  • maybe it is even a driver issue, but thats just a guess. I only got the request to accept a network driver with the first installation. But everytime i try to install again, I'm not asked anymore to accept a networt driver... (and of course installing again still doesn't work. i tried it dozens of times...)

This discussion has been closed.