Registration for F-Secure Safe failes

I'm trying register a new F-Secure Safe on my new PC (Lenovo Yoga 3, Win 8.1) but it keeps failing as the tool says "Oops, something went wrrong. Try again" and password fields are empty but other fields I filled remain with the content I entered there. Tried several passwords (min 6 characters with both upper and lower case). Also retyped several times the code from the product case I bought at the same time as my new PC. What's wrong?

Comments

  • SimonSimon Posts: 2,653 Superuser
    Difficult to say. The error message isn't all that helpful is it! Smiley Sad

    Is the registration code you're using definitely for SAFE? The codes are relative to the products, so if the boxed product is Internet Security, for example, the code won't work for SAFE. Not suggesting you're wrong, just saying there's a difference.

    Otherwise, it could be a code error - letter O instead of 0 (zero) for example, or an odd password character?

    Sorry to only be stating the obvious, but it's often a good place to start. :)
  • teacarteacar Posts: 2

    Thanks for your reply and as you say the suggested fixes were the obvious ones and already checked ;-)

     

    However the registration error got solved by itself just by waiting for a couple of days. When I tried again a few days later the registration succeeded. My guess is that there were two potential resolutions for this problem:

     

    1. The registration/installation code needs to be activated by the reseller by informing F-Secure that it was sold to prevent unpaid (e.g. in a shoplifting case) code to be taken into use.

     

    2. I used mobile connection via 3G gsm network when I tried to register the first time. The next time when the registration succeeded I used a LAN cable to fixed land line. I don't understand why that would make any differerence but I've noticed that sometimes it does.

     

    BR Tea

This discussion has been closed.