F Secure Booster problem

Hello can anyone help.

My copy of F secure booster identifies drivers and applications that are outdated but is unable to update them.  It always come up with message 'error while downloading'.  Can anyone help please?

Comments

  • BenBen Posts: 2,641 F-Secure Product Expert

    Hello Jono,

     

    Sorry for the delay in the reply. Sounds like your firewall could blocking access to the downloads.

     

  • jonojono Posts: 9

    Hi Ben,

    Thanks for the reply.  I tried your suggestion and turned off my firewall but I still have the same problem.  I am running XP and F Secure Internet Security.  

    I usually do not have to turn off my firewall to download files form the net.   Can you suggest something else that may be causing the  'error while downloading' message  on F Secure Booster please?

    Best regards,

    Jono

  • LakshLaksh Posts: 4,444 Community Manager

    Hi Jono,

     

    I am checking with the Product Experts for more information on this issue. I will get back to you soon once I get the details.

  • LakshLaksh Posts: 4,444 Community Manager

    Hi Jono,

     

    We got the information to troubleshoot further. Please try to check if you have the protocols enabled, it might be that the TLS is not enabled.

     

    Can you please try the following:

    Go to the Windows Control Panel and set the view to Large Icons.

    Locate the Internet Options icon and double click on it. Then go to Advanced along the top. Then locate the "Use TLS 1.0", "Use TLS 1.1" and "Use TLS 1.2" settings and make sure they are all checked.

    Then click on Apply and OK. Restart your machine try the activation again.

     

  • jonojono Posts: 9

    Hi Lakash,

    Thanks for prompt replies - much appreciated.

    I have looked at TLS enable as suggested.  Unfortunately 1 only have "Use TLS 1.0"  in my advanced settings.  However, I do have "Use SSL 3", which is checked and "Use SSL2" which is unchecked.   Should I check that - please can you advise?

    Thanks for your help.

    Best regards,

    Jono

  • LakshLaksh Posts: 4,444 Community Manager

    Hi @jono,

     

    Sorry for the delay in replying, just got an update on your issue.

     

    Enabling SSL2 will likely not help on this issue. However, we are suspecting there might be something on the computer which is blocking the download. Do you have any other Anti-spyware or Anti-virus programs installed on your computer apart from the FSIS?

    Could you try to turn off your Firewall or AV and retry the download just to see if it works?

     

  • jonojono Posts: 9

    Hi Laksh,

    Thanks for your help it is much appreciated.

    Sorry for delay in replying 1 have just returned from a long weekend away.  

    As suggested, I turned off virus protection, deepscan, and firewall through FSIS and re-tried the download of an application and a driver.  Unfortunately, I still have the same 'error while downloading' message.  I recently installed a trial version malwarebytes anti malware but this was after the problem was highlighted.  I am not aware of any other AV software.  Is there an easy way for me to check?  As previously mentioned I do not usually need to turn off AV software nor the firewall to download software.

    Best regards,

    Jono

     

  • LakshLaksh Posts: 4,444 Community Manager

    Alright @jono, you can always check if you have any other Anti-virus program in your Control Panel > Programs and Features. This will be the place for you to check if you have installed any other AV programs apart from FSIS or Malwarebytes.

  • jonojono Posts: 9

    Hi Laksh,

    Thanks again for your help (and patience).

    I searched through my programs and the only other AV type program I could recognise was Trusteer Endpoint Protection, which I turned off and tried to download updates through Booster.  Still no success. However, I did not turn off the other AV  and malware at the same time.  I could send a screen dump of my programs list, if that would help

    Best regards,

    Jono

  • LakshLaksh Posts: 4,444 Community Manager

    Hi Jono,

     

    May be try to turn off the other 2 AV as well and retry the download? If it still does not work, please update me and I will check with the respective team if logs might be needed for further analysis.

  • jonojono Posts: 9

    Hi Laksh,

    Thanks for message.  I have just turned off Trusteer plus the other two AV but I am still getting the same message when I try to download updates.  I look forward to hearing more. Thanks for your help.  

    Best regards,

    Jono

  • jonojono Posts: 9

    Hi Laksh,

    Further to my last reply I have just switched to Firefox from Opera.  Firefox has identified all my outdated plugins etc as does Booster.  I clicked on 'download updated version'  (through Firefox screen) of Adobe Flash Player and it downloaded without problem.  I did not have to turn off my AV's etc.  It does looks to me as if F-Secure Booster has an issue and it is not my AV etc preventing downloading through Booster.

    I look forward to your comments.

    Thanks again for your help.

    Best regards,

    Jono

     

  • LakshLaksh Posts: 4,444 Community Manager

    Hi Jono,

     

    Thanks for the update. Could you try to reset the Internet settings for IE as mentioned in here and retry the download?

  • jonojono Posts: 9

    Hi Laksh,

    Thanks for your reply and help.  Forgive my stupidity (and for my education) can you say why if I am running firefox as my browser why do I need to reset the internet setting for IE.

    Look forward to hearing from you.

    Best regards,

    John

  • LakshLaksh Posts: 4,444 Community Manager

    Hi jono,

     

    Thanks for patiently waiting and trying the steps for this issue. The issue was able to be reproduced and we are expecting an update for the program next week that should resolve this. 

     

    I will keep you updated on this.

  • jonojono Posts: 9

    Hi Laksh,

    Brilliant, thanks for that.  I appreciate the effort that has been put in to this.

    Best regards,

    Jono

This discussion has been closed.