Windows 7 Registry Problems

I am a very satisfied F-Secure Internet Security customer. Since I liked the product so much I decided to try the Booster program. The Booster program has caused my nothing but problems since I installed it!!

My Dell i7 pc developed the following issues since I installed and used Booster:

Booster Version-2.3.2.657, Windows 7-64 bit service Pack 1,

  • My Microsoft Office programs would not open. Word and Excel are asking for the product key but when I enter it will not accept, MS message says it’s a good key. (I went to Microsoft web site and found a repair utility. After running the utility I was able to get MS Office to accept my product key. Office is up and running.)
  • Every time I reboot a screen asks me to install HP Product Essential MSI and HP Photo Essential.MSI., I have not used this program in 2 years and it is no longer installed on my PC. The error message is "the feature is on a network resource that is unavailable".
  • The Quicken by Intuit program had the following error message when I tried to open, program files are damaged, reinstall the software. (I reinstalled the Quicken software and the program is up and running.)
  • F-Secure Internet Security program was damaged! Upon PC boot up I received a message asking for my subscription key. I tried to reinstall the software but the install kept failing, no reason was given. (I called F-Secure support and technician explained what had to be done to reinstall. My F-Secure Internet Security is up and working.)
  • The password protection program I have installed also lost its subscription key. Fortunately that was up and running once I entered the key.
  • My issue for today!! When I go to Control Panel and click “View Devices and Printers” the window does not open. (I went to the Microsoft web site and found several fixes, neither worked. They suggested using: ”Fix It” and going to “services” to start Bluetooth. I did both and I still cannot access Devices and Printers).
  • The Booster program is missing from my PC. I did not uninstall the program. I do have a valid subscription key for 3 PC’s.
  • All my saved user names for Google, banking sites, credit card sites are gone! I never save passwords, I only save user names. Why would your program delete user names?
  • The wallpaper on my desktop was gone, I tried to reinstall it but it would not take? After my third reboot the original wallpaper was back?

When I installed Booster I used the following features on day 1:

“Clean”

  • Delete unnecessary files
  • Save Power
  • Clean registry
  • Speed up registry


 

“Speed Up”

  • Boost start up
  • Increase Internet speed
  • Improve drive speed

I did not experience any of the above problems after I completed the above actions. But I did not reboot until the following day.

On the 2 day of using Booster I used the following features:

“Upate”

  • Clear browsing history
  • Update applications – I updated the following
    • Broadcom Net Xtreme
    • Realtek High Definition Audio
  • Remove Applications – I removed
    • Search Tool Bar
    • Ask Tool Bar

After a cold boot all of the above started to happen.

I thought this was supposed to be an easy product to use? What would happen to a novice PC user who installed and used this program? It appears that mu Windows Registry has been upset.

Additional information

I purchased a 3 key licenses from Booster. I installed Booster on my wife’s Sony Windows 7 laptop. She ran the clean and speed up programs from Booster on her PC. She is experiencing many of the same issues.

  • Booster is still on the PC but F-Secure Internet Security is missing.
  • View Devices and Printers will not open.
  • The Intel 5 processor now takes 5+ minutes to boot up.
  • MS Office is missing from programs.
  • When booted Windows gives a message that it can’t log in her user. It defaults to a guest user.

 

How do I get up and running again? How do I get my money back? Please do not tell me to call Microsoft and HP to get my problems resolved. Booster caused the problems and I expect you to supply answers.

John M.

US

Comments

  • Hi,

    This sounds almost exactly like my experience of Booster! It seems especially galling that it doesn't even appear to have been tested with F-Secure's own products. I contacted F-Secure, who replied by referring me to this site. In an ideal world, Iwish I had never tried Booster.Nothing but a pain. I want my money back!

    nickoakley

  • BenBen Posts: 2,640 F-Secure Product Expert

    Hi JohnSC and nickoakley

     

    I escalated your request, and we'll get back to you as soon as possible.

  • JohnSCJohnSC Posts: 3

    The problems on wy wife's PC have intensified.

    I cold booted the PC for the fourth or fith time. It will no longer boot to Windows. When booting up the PC asks if I want to start windows normally or run the Windows repair utility to fix Windows errors. I have selected each of the above and the same thing happens for both. The PC boots to a blue screen, no icons and no activity. PC does not respond.

    Sony with Intel 5 processor. Windows 7 (not sure about the service pack number)

  • I have also tried to contact Customer Support and just got refered back to this site. I am running Vista, If I run Clean up, it Blue Screens.

        I also would suggest, that Booster has not been tested and I too would like a refund. But it is like pulling Hens Teeth.

        There are also items, I cannot open within the Control Panel. It has really messed up my PC.

  • BenBen Posts: 2,640 F-Secure Product Expert

    Hi all, 

     

    Concerning refunds, Cleverbridge AG is the F-Secure reseller and partner for all purchases in our webstore. You can get a refund ("30 day money back guarantee") by contacting them directly.

    You should find the contact information on the communication you received from Cleverbridge.

  • BenBen Posts: 2,640 F-Secure Product Expert

    Hello JohnSC,

     

    We unfortunately cannot reproduce the problems you reported.

     

    Concerning the problem with the bluescreens on one of your machine, this seems unlikely that booster yield such results. It could well be a hardware failure and you might want to investigate in that direction.

     

    Could you try to reinstall Windows on this machine or restore to factory standards? If the problem continue that would clearly indicate a hardware failure. 

  • JohnSCJohnSC Posts: 3
    Ben,
    I am confident that Booster caused problems on both of my PC's. It is not fate or hardware problems. I suggest that your support people contact me directly. Just because your support people could not recreate the problem does not mean Booster is not responsible!!
    My Dell pc is up and running. Whenever I cold boot I get a message that F-Secure would not start and I would have to boot again. F-Secure works after the second boot. Why do I only get this error for F-secure?
    As far as my second Sony pc goes, I had the same thought as your support people. I thought that I might have a hardware problem. We are both incorrect. I tested memory and hard drive and both work. After several hours of trial and error attempt to access Windows I was finally able to get in under Safe Mode. I went to restore my start point and found the only 1 point left, for July 15th. I am back onto the PC now. The Booster, F-Secure, and Office programs are all missing. The Laptop is slower than ever.
    I think it is about time that Booster support starts taking some responsibility for a poorly written program.
    I need my problem fixed and your employer needs to do it. I have invested 6 to 8 hours of my time fixing problems I did not have until I installed Booster.
    I am not going to go away until my issues are resolved.
This discussion has been closed.