I can't download ANYTHING (with F-Secure SAFE)


 I just bought F-Secure SAFE (Internet Security) for my Asus ROG G751 JT Windows 8.1, because in my other computer it worked perfectly. But since I installed it, I haven't been able to download anything from Internet Explorer - and I've tried Google Chrome, Origin and Steam. 


After I installed F-Secure, my internet-connection went really bad: I couldn't get any sites open or it took ages. When I closed F-Secure for a moment, it worked, but I still couldn't download anything. Then I did some research and noticed that if you have two Antivirus' (or whatever they are called), for an example McAfee and F-Secure (which I had), they wont work. So I rebooted my computer, deleted McAfee and installed F-Secure again. Well, after that, my internet connection got much faster, but I am still not able to download aaaanything. When I try, it says that "network failed" or something about Windows Smartscreen stopping it from downloading. It even said that the program is not compatible with your computer (this happened wit Google Chrome, which is funny because earlier, when I didn't have F-Secure, it downloaded and worked just fine). I stopped Smartscreen and tried to download, but it had absolutely zero effects.


Yes, I'm almost in tears now, and desperate for help. Anyone?


This discussion has been closed.
Pricing & Product Info