IS 2012 + Windows XP SP3 slow d/l speeds...

I have both Windows 7 (SP1) and Windows XP (SP3) installed on my PC. Windows 7 with Internet Security 2012 is working perfectly, but on Windows XP download and upload speeds are 1/20 what they should be. Even if I disable the firewall and everything, there's no change in speed. When uninstalled, it goes back to normal and I can download with full speed again.

I had Avast + Sunbelt firewall previously installed, and they worked like a charm.


I have installed new drivers for NIC and tried to run TPC Optimizer, but the problem persists.


  • I have the same problem.

    I have Linux installed on laptop and  download speed is 46.57 Mbps.

    When I work with Windows xp SP3, download speed decreases to 8 Mbps. That's 40 Mbps difference !!

    I tried to disable antivirus and deepguard and firewall too, but nothing changed


    Please help 

  • MJ-perComp
    MJ-perComp Posts: 432 Superuser

    disable web traffic scanning and reboot before you test to get the drivers unloaded propperly

  • disabling web traffic scanning didn't solve the problem

  • Frisjo
    Frisjo Posts: 47 Enthusiast

    Go to add and remove programs, select to uninstall F-secure launch pad and then uninstalled marked features. Select to uninstall Online safty.


    This is the component that have the parentalcontroll and so on.


    Does it work better?


    If you want to install it again you can rightclick the F-secure systray icon and select Show my subscriptions and in this windows select installation status in the list to the left. And here select install.

  • flogger
    flogger Posts: 35

    Has anyone tried totally uninstalling it and see if the download speed improves? 


    I'm thinking that this is that route that I will go to prove my theory. 

  • makis
    makis Posts: 12 Observer


    I had the same problem,which solved only when I totaly uninstall the FSIS 2012.I went back to FSIS 2011,and everything works fine again Smiley Happy

  • makis
    makis Posts: 12 Observer

    Hello again,

    I have good news!I tried,once again,to install FSIS 2012 and seems that the problem is no longer exists.

    Please follow these steps:

    1.Download FSIS 2012 installer

    2.Download and run F-Secure uninstallaton tool

    3.After reboot,make a search for leftover folders and files,(better in safe mode)and delete everything found

    4.Now,run the installer

    Please,remember to write down yours license number,before these steps



    Welldone F-Secure! 

  • Frisjo
    Frisjo Posts: 47 Enthusiast

    Its ok just to uninstall from controllpanel and then install whit a newly downloaded installation package.

    Or wait for the uppdate to come as an automatic uppdate that schould come soon.

This discussion has been closed.
Pricing & Product Info