cannot even

Lauri_HLauri_H Posts: 59 Former F-Secure Employee
Hello
Cannot purchase since freedome says "cant find your subscription" and pressing retry is only option.

Comments

  • BenBen Posts: 2,641 F-Secure Product Expert

    Hello Lauri_H,

     

    You should be able to purchase our product from our web store or the app-stores.

    At which point do you encounter the error?

  • glauriglauri Posts: 1

    Ok hello again,

    It appears that my old credentials got axxed, and I had to re-register. =) 

     

    Nonetheless, 

    I had a subscription at some point, I don't have one now. When I install freedome, it ends up in the state that there is no trial, and it tried to guide me to purchase a subscription, which I would actually like to do. But in the screen [1]  It just says that FREE Subscribe now, and then it states that could not restore. The retry button changes to a spinner if I click it and then it states the same thing. Link to screenshot attached. I have tried clearing data and re-installing but it doesn't work. I got a keycode ( which I was unable to insert except by reinstalling and inputting the code in the start ) and that was accepted but it ended up leading to the same situation. 

     

     

    Other than, good job with the ( beta) feature of allowing trusted networks, I'm looking forward to giving that a try to be able to stream geoblocked content to tv via chromecast! yay for that. 

     

    ++lauri

     

    [1]: https://www.dropbox.com/s/1aw0txu6fcd5fzy/freedome_fail.png?dl=0

This discussion has been closed.