Freedom activation failed

Anti Posts: 2 New Member



I have freedom activation problem in iPad.

I purchased licence( 3 devices, one is activated in android phone) from fsecure web page and tried to activate it in iPad(2nd device).

I have network connection (tested) and the trial version of freedom worked fine in my ipad.

I tried restarting, wifi on and off,  reinstalling app, etc but without any success. Still same messages.

What i should do?




  • Tehfcae
    Tehfcae Posts: 107 Contributor

    First should check for updates to iOS or Freedome.


    Next try removing and readding the VPN profile:


    1. Settings > General

    2. Profile

    3. F-secure Freedome

    4. Delete Profile

    5. Settings > Safari

    6. Allow pop-ups

    7. Allow cookies

    8. Advanced

    9. Allow Java script

    10. Open FreeDome and attempt to connect again.


    You may also want to try restarting your iPad.

  • Anti
    Anti Posts: 2 New Member
This discussion has been closed.
Product & Pricing Info