iPad with Freedome - country changes in Freedome but applications don't accept it

I installed Freedome yesterday from Appstore in my iPad running iOs 8.3. Installation went nicely, I created the profile for Freedome, started the security control and changed the country to Finland. However, the applications which I tested did not open, because they said my physical location (spain)  will not allow them to start.

 

Is there anything else I should do in iPad to make Freedome work ?

- I have re-installed the applications which I would like to use

- I have booted the iPad

- I tried to use the applications through the browser

 

With my MacBook everything works nicely with Freedome.

 

Any ideas ?

Best Answer

Comments

  • BenBen Posts: 2,641 F-Secure Product Expert

    Hi Markkusilen,

     

    This problem could be due to improper geolocation of the applications your tried to use on your Ipad.

    See this article for more information. 

     

    What were the applications which failed to open?

  • The same applications (Katsomo) work fine with Freedome & MacBook/Safari but not in iPad.

This discussion has been closed.