Automatic connetion after Windows 8.1 has been in a sleep

Freeworld Posts: 10 New Member

Freedome don´t connet automatically after Windows 8.1 has been in a sleep. Avast VPN does that. That is the big shortage of Freedome.


Avast has also better information in a icon are you connected or not, using x - not conected and other colour when connected.


If Freedome lose connection to VPN server how Freedome operates then? I mean does Freedome allow surfing in the internet not protected? If so it is easy to break protection to cut connection to VPN server. Avast has that shortage althoug it informs the isue, but usually an user don't notice that. I my opinion Freedome shoud stop networking and ask user what to do.




  • Tehfcae
    Tehfcae Posts: 107 Contributor

    FreeDome can be added to your start up list. This will make it start automatically upon login.


    1. Open up task manager.

    2. Go to Startup tab.

    3. Right click Freedome

    4. Select enable.


    Freedome needs to be on in order to provide protection. Freedome allows surfing with it being disabled for many reasons. Amoung them being connecting to local network drives, connecting to network printers, monitoring network traffic, connecting to a different VPN serverice, and other reasons. 


    If the Freedome icon is blue and still it is connected If it is Blue and the icon going up and down then it is trying to connect. If the icon is grey, it is not connected.


    The connection break must happen on your machines end. An attacker that is not on your machine will not be able to force you to disconnect from the server. If an attacker is on the machine and is able to disable Freedome remotely they would not need to disable it as they could monitor plain text traffic before it get encrypted by Freedome.

  • Freeworld
    Freeworld Posts: 10 New Member

    My selection is enabeled in task manager. Freedome settings are also enabeled: Freedome starts automatically when you restart your coputer and also Freedome turn on protection automatically when it starts.


    But if you don´t shut down a computer but you just put a computer in a sleep or hypernated and after that you turn your computer on, Freedome don´t continue protecting networking. You have to do it manually. Automatic restoring is needed new feature.


    Avast restores VPN automatically after sleep-mode, Freedome don´t.

  • Tehfcae
    Tehfcae Posts: 107 Contributor

    Setting a computer to sleep is supposed to only suspened a program not close it and FreeDome is supposed to continue after being in sleep mode. I have been unable to reproduce the issue as FreeDome is remaining open while the computer set to lock and getting suspended properly went set to sleep on my machines.


    The issue is pretaining to your machine specifically and not FreeDome as a whole. If their are OS updates or updates to FreeDome I recommend installing those and then restarting your machine.



  • Freeworld
    Freeworld Posts: 10 New Member

    I have noticed that Freedome lose connetion when computer is started after been in a sleep and Freedome don´t try to connect again. It takes a while Windows to establis internet connection in my Leonovo Z50 Windows 8.1 laptop.


    I suspect that Freedome is not able to wait couple of seconds when computer establish contention to internet via Wifi to Wifi modem. After computer has establish conection to internet, I have to manually start protection in Freedome. I propose that Freedome should try to connect until user stops Freedome after computer is started afteer sleep-mode.


    Does Freedome automatically check updates? If not so, where I find lates updates?

  • anfo
    anfo Posts: 4

    Hi, same here.


    Putting the computer into sleep mode (RAM) or hibernate (disk) means a manual reconnect after wakeup - but not on every computer every time. Looks like if when there is no network connection the reconnect fails completely, even network is restored a fraction of a second later.


    Wireless and wired connections, W 8.1 x64 with all available updates/fixes installed.


    OT: What I found out also is that Freedome blocks WakeOnLan on a local network when activated, but to be honest I did not try other vpn services so I don't know if this is a usual behavoir ;-)



    CIA_MAN Posts: 27 Observer
    Same at my computer... Also Windows 8.1 in use ... Smiley Sad
  • Freeworld
    Freeworld Posts: 10 New Member

    Freedome has a new update 1.01517.0. The newest version don´t establish connection automatically after computer has been in a sleep or hypernated. The bug still exist. I hope F-secure fix the problem quickly.


  • Freeworld
    Freeworld Posts: 10 New Member

    The latest verision  1.0.1565.0 don´t work. I think Freedome don´t chech or wait enough long time to reconect to the server. If Avast Secure Line can resume connection after a computer has been in a sleep (or hypernated), so Freedome should do. This is a security issue.


  • Freeworld
    Freeworld Posts: 10 New Member

    Version 1.0.1712  don´t work. The software has too much bugies.

This discussion has been closed.
Product & Pricing Info