TP138 Windows Client Release

VilleVille Posts: 515 F-Secure Employee

FS Protection PC Release 138


  • Common Component Framework 2.38 build 257
  • Antivirus 14.138 build 100
  • Browsing protection 2.138 build 3418

Fixed issues

  • License expired status for few minutes after install in rare cases (CTS-96292)
  • Action Center messages are missing large icons (CTS-96253)
  • Error situations may expose underlying key when login is used (CTS-96221)
  • Unicode character rendering problems in About (CTS-96214)


  • Icon size incorrect after QT5 upgrade (CTS-96241)
  • OAS and HIPS prompts unusable (CTS-96238)
  • F-Secure Anti Virus has Spam Filtering updates in Database Update (CTS-95983)
  • Extra space between help button and dialog border (CTS-96280)
  • Reboot after malware removal from OAS detection not working under remote desktop (CTS-96235)
  • Submit dialog title text color customization missing (CTS-96187)

Known issues:

  • On languages other than English, the setup dialog title may be missing or malformed. This is due to missing localizations and will be fixed in next release.




  • It wont update!? using windows 10.

  • qroonqroonqroonqroon Posts: 3

    Do you want to know what are the preferential goods this month?Paradise for game enthusiasts, hurriedly click here:[URL=]RS Gold[/URL]

  • yeoldfartyeoldfart Posts: 513 Superuser
    it says I only have 18 days left ! can it be true ?
  • UkkoUkko Posts: 3,198 Superuser



    Probably, yes. It's can be normal.

    As example.. with FS Protection portal I have same information about account.


    Little additional:  In fact.. I can not to check it with My FS Protection portal, because there new "access denied" page during try to use link for visit. But recently it was related with same "days for expired".

    And it's same with Windows Phone client.

     But will be a little be another situation with Android (there one day more) :) .

  • yeoldfartyeoldfart Posts: 513 Superuser

    hello Ukko

    same "access denied here" fault is on FS  side

  • VilleVille Posts: 515 F-Secure Employee

    Hi @korven_perkele


    Please create a bug report at Also attach support tool output (fsdiag.7z) and screenshot if there is any error message.



    (F-Secure R&D)


  • yeoldfartyeoldfart Posts: 513 Superuser

    thank you, this was on server side, been repaired since

  • UkkoUkko Posts: 3,198 Superuser



    Sorry for my reply. Sorry for long reply Smiley Sad .

    Just interesting to ask.


    Does it's can be anyway.. my local experience (?!) after new points for me?


    --About Browsing Protection plugins, HTTPS features and EPM or 64bit--




    Already probably three (or more) TPs ago... I get situation with Windows 8 device, where plugins (for HTTPS support/SafeSearch feature for Google) does not work with fresh/clean installation.

    Plugins installed - but it's not work. Such as with HTTPS missing rating pictures, does not work SafeSearch (but it's anyway not really work.. and just with Google maybe) with Google HTTPS. And related things.

    Any of steps does not created something more, than... "so.. probably it's can be not my local experience and can be known". It was reported (twice probably, because was additional).


    Today I briefly get situation and check it with Windows 8.1 (and latest updates; I thought before.. that it's can be related with some of Windows 8 outdated points).

    So... it was indeed work. But after that I goes to check "my dreams about potential reasons" (which should be known - if it's indeed main reason). And re-check some settings (incldue EPM).


    With EPM enabled it's not work.


    Does it mean.... that all other users of FS Protection also with same design?! Or it's anyway my local experience?!

    In fact.. there another point can be:

    With Windows 8 probably there just one settings/option for EPM. And it was enabled and plugin works before latest TPs (also during first time/long time ago.. it was not work. such as HTTPS plugins/extensions does not work with EPM. It was fixed long time ago; So and I not thought about it as main reason. Such as it was not really likely that reason just with current point again).


    With Windows 8.1 there have more options for EPM. And current one... probably related with "trouble":


    ""Enable 64-bit processes for EPM (Enhanced Protected Mode)""


    When it's checked/enabled...  F-Secure Browsing Protection (for HTTPS support) does not work.

    Rating pictures missing. SafeSearch for search-engine does not work.


    So.. it's looks like that probably known (?!) and not my local experience - but still not sure.. does it's indeed like that. Because release-notes does not have something temporary about this trouble (!?). And maybe there was enough time.. if it possible to fix this?! And probably it's can be that.. someone else can to ask it under community?! But I not really meet something of this.


    Maybe someone else have same experience? And I not really need to think how to get normal previous experience.


  • FengpingFengping Posts: 50 F-Secure Employee

    Hello @Ukko,

    I dont have problem in my Windows8.1 with IE11, search result show rating icons with EPM enabled or disabled. Please report a case if your problem persist.


  • UkkoUkko Posts: 3,198 Superuser



    Sorry for delay with my answer.


    On current time I can not to re-check it again with Windows 8.1 (64bit?!)/Internet Explorer 11.

    And not sure.. now.. what if it random (?!). And fsdiag (from current machine) does not created.


    But I goes to get "workaround" now. I tried to use virtual machine with Windows 8.1 / Internet Explorer 11 (all latest updates). So.. with current background..... I also get troubles with F-Secure extension (for HTTPS) and work of plugins. Search results not comes with rating-pictures and other related points.

    Also there same with "main" situation (from "main" device and not from virtual machine).... it's available to get back rating-pictures (for HTTPS and other features)... if I launch Internet Explorer as Administrator (from context-menu).

    Additional points: virtual machine launched under "main" machine (where comes situation). There normal UAC-account too.


     Can it's be valid report-description/fsdiag from virtual machine?

    As additional/repeat (from previous reply) - maybe it's not really related with EPM.

    Such as it's also work for me (search result show rating pictures with EPM enabled/disabled).


    But when there enabled next option/setting (it's another one.. there have option for EPM as turn ON it. And something else). It's called as checkbox:


    ""Enable 64-bit processes for EPM (Enhanced Protected Mode)"""


    When it's "enabled" (checked) - plugins/extensions does not work.

    With Windows 8 machine there I not really find same option. But extension does not work too (!?).




  • FengpingFengping Posts: 50 F-Secure Employee

    Hello @Ukko

    Thanks to your observation we did identify some glitch with EPM, the fix should be available on next TP, please check it out.

    Update on the coming release: the fix wont make it to TP139, likely the one after.

  • VilleVille Posts: 515 F-Secure Employee

    Hi @Ukko


    Do you mean support tool fails to create fsdiag.7z on your computer? Can you please create a bug report in and attach C:\ProgramData\F-Secure\Logs\CCF\fsdiag.log



    (F-Secure R&D)


  • UkkoUkko Posts: 3,198 Superuser



    No, with fsdiag.7z (Support Tool) was all OK.

    I just forget to create fsdiag under current machine . But basically.. it was created before. It's mean all OK with machine.
    I mean: I does not create it and I does not get it from machine after "check" situation. And on current time I not able to get this too (because not able to use this computer; such as computer not available to be in use).


    Sorry for my previous hard explanation.

This discussion has been closed.