Still a lot of connectproblem on OS 8.3 and Iphone 6


I use Freedome V2.1.3.1683 on my iPhone 6 with OS 8.3 (12F70).
There are a lot of connection problems. I'm prompted to reboot the device to remove the problem, but it does'nt.
I also have an iPad and the device does not occur this problem very often.
I have had this problem since the summer of 2014. It is high time that the problem is solved for good.

Kind Regards,

Accepted Answer


  • TehfcaeTehfcae Posts: 107

    Try uninstalling the profile from your settings menu and trying to connect again.


    If that doesn't work try uninstalling and reinstalling the app.

  • kennybekennybe Posts: 26
    I've tried both methods , but I did not get rid of the problem. I often get the call to restart the device and promised that the problem will not occur again . This is not true.
  • kennybekennybe Posts: 26

    I often had to restart my divice (Iphone 6) but i does not solv the problem. 

    Despite new update to iOS 8.3 with the task of VPN-problem corrected the problem remains. Who own the problem F-secure or Apple? This is a problem since I subsribe the program i summer 2014.  




  • TehfcaeTehfcae Posts: 107
    What this looks like is an issue with your iOS device installing the VPN profile.

    Make sure Safari is allowing JavaScript.

    Settings > Safari > Advanced > Check JavaScript and try again.
  • kennybekennybe Posts: 26
    Sorry, javascript is enabled.
  • kennybekennybe Posts: 26
    I deleted Freedome, restarted, installed again and tryed to stream a video in Safari.
    Immediately it was locked and I was pomted to restart my device.
  • TehfcaeTehfcae Posts: 107
    You may need to allow pop ups and cookies when installing the profile.

    So uninstall the profile, check those settings then try again.

    Also check for OS updates and updates to Freedome.
  • kennybekennybe Posts: 26
    I have done everything according to your proposal, without effect.
  • kennybekennybe Posts: 26
    My experience of the tests on iPad Air and IPhone 6 with IOS 8.3 shows that Freedome is working on iPad, but on the IPhone 6 may be often interruption of the connection. If you cannot solve the problem, you should report the fault to the Apple.
  • kennybekennybe Posts: 26
    I can`t use Freedome on my Iphone 6 though I downloded ver 2.1.8. I get very often stop in the traffic.
    Are you going to solv this problem?
    I have payed for the licens since july 2014 and have not been able to make full use of the program Iphone devises.
This discussion has been closed.