This is not okay.

Can someone please speak some sense to me here? I set off the anti-theft alarm on my tablet yesterday to find where it was within my home. It said this was an alarm you can set off to locate it, so I did. I found it. I now cannot get the alarm to stop. It's asking for a password and I don't know/remember what password this would be. I've tried all my usual passwords.

 

The website says you can send an SMS to the device to stop it, but as it's a tablet, there is no number to send this SMS to. It also says if I contact them they can reset the password. I tried chat and the technician just cut off the chat before even talking to me within  2O minutes. I called up the UK number and got a lady who told me I have to have proof of purchase to reset it? Really?! For a tablet I got FREE with my mobile phone contract over a year ago?! I don't have the proof of purchase! 

 

I cannot use my tablet AT ALL. It will not let me unlock it and constantly sounds an extremely loud alarm the whole time its on so I have to keep it off. I am so annoyed that my tablet is now completely useless due to using one of your services. I have the email address I signed up for F-SECURE on via my Virgin Media subscription service. I have proof that I am the person who started the account (my name on my passport). I have the phone numbers of ALL the other devices that this anti-theft is installed onto. I live at the same address. I am DEFINITELY the owner of this tablet. No thief would have all of that information AND access to the F-SECURE account, hotmail email account AND my home address, yet still I am not allowed to reset my anti-theft password? Really?

 

Can someone please help me out here? I am so at my wits end and just want the use of my tablet back!!!

Answers

This discussion has been closed.