SAFE Banking Protection wont' load

It's odd.  Yesterday my banking protection worked.  Today it doesn't.  I don't have an option to turn it on.  Anyone have advice? 

Best Answer

  • SimonSimon Posts: 2,574
    Accepted Answer
    The first thing I would try is to reinstall the browser extensions from the Browsing Protection screen, followed by a reboot.

    The next step would be to try a different browser and see if the issue still remains. If BP then works, perhaps your original browser has had an update which has knocked out the Browsing / Banking protection?

    If none of the above does any good, then try reinstalling F-Secure.

    Let us know how you get on. :)

Answers

  • VilleVille Posts: 479

    Hi

     

    If you have Windows 8 or newer, please open task manager and go to "Startup" tab. Make sure you have not disabled "F-Secure Host Process". That is the user interface of our product and if it's disabled, you will not receive any notifications.

     

    Ville

    (F-Secure R&D)

     

  • BhangerBhanger Posts: 2

    Looks like reloading the extension worked.  Thanks.  I also had to sign into Chrome for it to work. 

This discussion has been closed.