freedome subscription problem

Hi,

I`ve been using freedome almost 2 weeks. Suddenly it stopped working. I reinstalled it but now it do not accept the same subscription code that I bought 20.2.2015. It says that subscription has expired although it should last 12 months.

 

win 8 

 

 

 

Accepted Answer

«1

Comments

  • ValhallaValhalla Posts: 9

    Im having a similar issue, I have been using Freedome on 1 PC and 2 apple devices since the purchase of freedome for PC, and suddenly as of yesterday my subscription code cant be entered on my iphone.

     

    According to my purchase details Im allowed to use freedome on 3 devices.

  • BenBen Posts: 2,641 F-Secure Product Expert

    Hello Valhalla,

     

    Did you reset or reinstall freedome on you iphone? Did you experience any issue with it, that you needed to enter the subscription again?

    Valhalla
  • ValhallaValhalla Posts: 9

    I unstalled and reinstalled freedome on Iphone IOS a couple of times after having connectivity issues.

  • TehfcaeTehfcae Posts: 107

    What iOS version are you on? 

     

    I had connectivity issues whenever I was not on the most recent version of iOS. You may also want to remove and readd the VPN profile by doing the following:

     

    1. Open Settings.

    2. Go to General.

    3. Go to Profile.

    4. Select F-secure Freedome.

    5. Delete Profile.

    6. Relauch app you should be prompted to install the certificate.

  • RsvTuRsvTu Posts: 5

    Hi 

     

    Also have problem that Freedome key is not accepted anymore after i had to re-install my android phone 3 times. Can you Ben release my key ? 

  • hi

    after a few days working the same problem came back. Freedome won´t work and it says "could not verify your code try again later.Subscription expired". This occured when I upgraded windows 8 to 8.1.

    Freedome works fine in win 8 but it does not work at all in 8.1.  Now I´m back in win 8. It seems to need subscription code during every reinstallation.

    The same code does not work anymore.

    Is there something else I can do to make it work than change the code every time .

     

  • BenBen Posts: 2,641 F-Secure Product Expert

    Hi hra_heinamaki,

     

    Could you try to reinstall using the short term voucher I provided to you by private message?

    Valhalla
  • After reinstalling freedome, codes you gave me worked again.

    Thank you for support!

     

  • ok
  • ValhallaValhalla Posts: 9
    Yes, I uninstalled and reinstalled it so i had to re-enter my subscription key.
  • ValhallaValhalla Posts: 9

    Thnx ben for sorting me out, freedome is working again after entering that code u sent in a private message.

  • PhoenixPhoenix Posts: 3

    Hi,

     

    The same thing is happening to me. I had to do a factory reset on my laptop and since then, whenever I use my code, all I'm getting is ""could not verify your code. Please try later". My 12 month subscription was only purchased in June and the only guidance I can find on here is confirming that it is due to the reinstall, but nothing on how to fix it.

     

    Any Ideas?

     

    Thanks

  • ValhallaValhalla Posts: 9

    Send the admins a message, Ben usually replies fast and is helpful.

  • PhoenixPhoenix Posts: 3

    Hi Valhalla,

     

    Thanks - although as new on here, not sure how I do that??

    Thanks

  • ValhallaValhalla Posts: 9

    Login to f-secure forum, click on the mail icon in the upper part of the screen and to the left of your forum name, click on compose letter.

  • PhoenixPhoenix Posts: 3

    Thanks!!

  • HailanHailan Posts: 61

    Hi Phoenix,

    I have sent you a new keycode via private message.

     

    Please keep in mind that a specific moderator might not always be available and it could take some time for them to reply to you if you message them directly, for example Ben is currently on vacation for a few weeks.

     

    Thanks

     

    Hailan

    Phoenix
  • eerikeerik Posts: 2
    Hi! After free trial period, I paid annual subscription (ios) two weeks ago, but now it claims that the subscription has expired. Tried to uninstall the app couple times without luck. How can I make it work again?
  • I have a similar problem. I'm using windows 10 technical preview and after upgrading my freedome to the latest firmware my subscription counter changed displaying only "trial" and 14 days left. I had approximately two years worth of days subscribed. Is there any way to resolve this?

  • BenBen Posts: 2,641 F-Secure Product Expert

    Hello,

     

    @eerik, did you try to restore your purchase from you IOS account?

     

    @jukkapoika , Could you give us more information of the version that changed your subscription? 

     

    Note that Technology Previews are usually not officially supported and only RTM version should be use with our products.


  • @Ben wrote:

    Hello,

     

    @jukkapoika , Could you give us more information of the version that changed your subscription? 

     

    Note that Technology Previews are usually not officially supported and only RTM version should be use with our products.


    I can only tell you that I'm now running version 1.0.1715.0. Before switching to windows 10 I copied the files from f-secure folder in program files to my dropbox fearing something like this would happen. Is that helpfull at all in this situation?

  • eerikeerik Posts: 2
    Yes, I tried to restore it without any luck. After few attempts I paid monthly fee again to make it work gain.
  • mpjmpj Posts: 2

    I have a problem with my annual subscription as well.

    I use Freedome (for 3 devices) with my:

    - desktop

    - laptop

    - android phone

     

    Few weeks ago I wet my Note4 and got S6 to replace that.

    When I tried to enter my code to the new phone I got an error that "the maximum number of devices has been reached".

    Obviously in some database my old Note4 is still linked to my code - perhaps because I was not able to uninstall Freedome from my old phone because I drowned it.

    How could I unlink the old phone to be able to use Freedome with my current phone.

     

    PS. I'm going to upgrade my desktop in a month or so (some parts and OS clean install W7 --> W10). What should I do so that I don't face the same problem again?

  • BenBen Posts: 2,641 F-Secure Product Expert

    Hello Mpj,

     

    It is unfortunately not currently possible to unlink your old phone. Our development team is working on this.

     

    I'll send you a private message to try and resolve this problem.

  • Hi Ben, others,

     

    now I have 6 subscriptions in total! and I can't afford to keep losing and buying more really. I need to reinstall my android and I asked before but got no answer. Now it is time to solve this because the reinstall must be done.

     

    There must be a way. I mean guys at F-Secure, seriously who does that which you are doing with freedome? 1 install and you call it a seat? I haven't seen a "seat" where you can only sit once and if you stand up you fly by the seat of your pants for good Smiley Happy

     

    thanks in advance ladies and gents...

     

     

  • BenBen Posts: 2,641 F-Secure Product Expert

    Hi Moerbid,

     

    I sent you a new PM on that topic.

  • hi

    i have new freedome version 2.0.25.2756. After updating to this  version , my code stopped working.

    Only app security is on.

    I'm using acer iconia B1 A71 tablet, with android version 4.1.2

     

    There's this text:give code or buy new one. I have'nt even used half of my lisence.

    (This is starting to be a bit annoying, playing with the codes. )

     

     

  • hi

    i have entered the subcription code on my andriod after accepting the code subcription did not change,

    can you fix the problem as soon as possible

  • NoeleNoele Posts: 3

    Completely frustrated. 

    1. I dont even know if I am posting this correctly. 

    However if I am here is the deal. I purchased the f-secure fredome for 5 products. HOWEVER.One of my laptops doesnt like the program and keeps rejecting it by not recognizing the product etc. So I have had to uninstall and re-install too many times. This last time the computer said that I had used up all of my instalations for that code. I am not buying another set of instalations. Now I have a computer that is not secure. 

     

    I hope I have done this correctly 

    Thanks 

This discussion has been closed.