Freedome connects to server, but no web access ?


I have been using Freedome for a while, but now it seems most locations/servers do not work. Today I tried several locations and only London, UK was working. Yesterday it was Germany that was working.

This has been going on for atleast a couple of days, before that there were no issues with changing my location.


I can connect (Freedome also says "connected"), but it seems I have no internet access after that. Chrome is trying to resolve host names (and apparently fails) so it might be a DNS issue. 


Is this only me or does someone else have similiar issues ?


- Sam



  • Ben
    Ben Posts: 2,641 F-Secure Product Expert

    Hello Sam74,


    Is the problem still happening today? Is all the traffic affected?

    Could you tell us which device you are using and on which type of network you try to connect to Freedome?

  • Sinuce
    Sinuce Posts: 5

    Hello @Ben,

    I am experiencing a similar issue to @Sam74 's;

    Freedome itself connects but I have no Internet access afterwards. I only regain connectivity when turning off Freedome entirely.


    My computer is running Windows 8.1 x64 system using Firefox 36.0.4 and I am on my university's wireless network.


    Freedome tends to fail as mentioned only while using specific wireless connections.

    On some wireless networks, everything is fine.

    On my home desktop (Win7, x64, Firefox, connected via Ethernet cable) Freedome works fine as well.


    Thank you for your time.




  • Sam74
    Sam74 Posts: 10



    Sorry, forgot to post my system details.


    My computer is also running Windows 8.1 x64. I am using a wired network connection. Freedome on my iPad seems to be working like before.


    I wil test later, but as I recall all network access was blocked after starting a Freedome VPN connection. Once I found a VPN server that worked then all functionality returned to normal.


    - Sam 

  • Sinuce
    Sinuce Posts: 5

    @Sam74Hmm... it does seem odd that you can connect through some of the VPN locations. In my case I can connect through any location or none at all, apparently depending on which network I am on.


    I found this post in the forums:

    Maybe certain networks or routers restrict some or all VPNs?

  • Ben
    Ben Posts: 2,641 F-Secure Product Expert

    Hello Sinuce,


    The network restriction in place on your university's network, could indeed be the reason for the behavior in your case.



  • Sinuce
    Sinuce Posts: 5

    @Ben  Hello Ben,


    Thank you for your swift response.

    That's what I suspected, sadly.


    It would be great if Freedome served feedback to the user, visualizing the error when Internet connectivity is limited on the network. Smiley Happy

This discussion has been closed.

📢F-Secure Quiz Challenge📢

Join our online quiz session on June 15th, 2023, at 11:00 AM EEST and stand a chance to win prizes.

Product & Pricing Info