optprosetup.exe

Hi

I have F-secure on a Win 8.1 OS. 

It comes up with a warning saying "Spyware detected: Type adware Family: Name: Adware.Generic.1184023

Object: Object: C:\Users\Rasmus\Appdata\ Local\Temp\optprosetup.exe"

 

I can't delete the application in spite of the fact that my user accounts have full persmission to access the file. It says that I should have permission from the administrator, but that's me!

The warning box has become a permanent fixture. It can't be removed either. I wonder if it is a genuine F-secure warning or it has been taken over by the malware. There is no sign of PC Optimizer Pro in the task manager otr elsewhere that I´m aware of.

What can I do about the problem?

Best

Rasmus

Best Answer

  • SimonSimon Posts: 2,582
    Accepted Answer
    As it appears to be in a Temp folder, have you tried something like CCleaner to clear out your Temp files? Or maybe Malwarebytes would be able to remove it? Failing that, maybe the file could be deleted in Safe Mode?

Answers

  • RasmusRasmus Posts: 4

    Hi Simon,

    Thank you for your prompt reply. The irony is that I already have Malwarebytes Pro running alongside F-secure. It donsn't detect this particular malware at all. I think optprosetup.exe came bundled with a program called drivermax that I was recommended.

    I'll try your other advice.

     

  • RasmusRasmus Posts: 4

    Hi Simon

    Safe mode did it. I have no idea how it seems to circumvent  what looks like a  permission issue.

    F-secure was very insistent about this file - which is probably just as well. It came up every 5 sec and made work impossible. Thank you for your promt assistance.

    Best Rasmus

  • SimonSimon Posts: 2,582
    Glad that worked. I think I might be tempted to run the Online Scanner now, just to check there's nothing else lurking:

    https://www.f-secure.com/en_GB/web/home_gb/online-scanner
This discussion has been closed.