Component upgrade failure

You seem to have some bad trouble with your installers. Two last times I have installed a new version of F-Secure Internet Security, I had to completely remove the old version before the installation succeeded. This month, a new trouble appeared. One of the component upgrades that F-Secure makes automatically failed. Usually I do not even notice that a component or a few have been upgraded, but this time I got a pop-up saying in Finnish that I have to reboot the computer to finish up the upgrade. I obliged, naturally, but I keep getting the same pop-up notice after every reboot. Sometimes the notice is in Finnish, sometimes in English, and oddly the text says very different things in these two languages.

In Finnish: "Uudelleenkäynnistys on pakollinen"

"Tietokonettasi ei ole suojattu täysin. Viimeistele päivitys tallentamalla tiedostot ja käynnistämällä tietokone uudelleen."

(My own translation: "Reboot is mandatory / Your computer is not fully protected. Finish the upgrade by saving your documents and rebooting the computer."


"The upgrade of Service Enabler was succesful. Please reboot your computer to complete the upgrade and start using the new version."

The computer is connected to the Internet all the time by LAN cable, and I have not had any probelms with the connection. When I check the general settings, I find one component whose upgrade has failed: "11.3.2015 15:56:23 CCF Basic 2.15.364".

Please do not tell me I hgave to run UninstallationTool.exe yet again just to get this one single component upgraded!


  • SimonSimon Posts: 2,661 Superuser

    @Hönö wrote:

    Please do not tell me I hgave to run UninstallationTool.exe yet again just to get this one single component upgraded!

    OK, I won't.  But that might be the simplest solution.  Try this first - the whole thing may not apply to you, but it might be worth running the tools in the last two points of the article:


  • HönöHönö Posts: 64

    Would you care to explain why you think the component "CCF Basic" (or "Service Enabler") has anything to do with the virus definitions?

  • SimonSimon Posts: 2,661 Superuser
    I don't, and I guess it perhaps wasn't the best thought out suggestion. I just thought the reset tool might have forced an update of all the components.
  • VilleVille Posts: 523 F-Secure Employee

    Hi @Hönö 


    I'm sorry to hear that you have had so much trouble with the installers.


    Unfortunately it looks like you have hit a rare bug in upgrade. The upgrade was a silent software upgrade that fixes the vulnerability The upgrade required reboot but something interrupted it in the middle and it didn't update all the states properly. Now it will keep asking for reboot forever. This bug has already been fixed in the beta version and will be released in next product upgrade.


    If you are comfortable with editing Windows registry, you could try to open regedit and remove the following key: HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\F-Secure\My Services Agent\Upgrade: IsUpgradeOngoing. (Leave 'Wow6432Node' away if you have 32-bit OS).


    Otherwise I'm afraid it's uninstall + reinstall once again.


    PS. "CCF Basic" and "Service Enabler" are internal project names for some components and should not be visible to users in GUI.



    (F-Secure R&D)


  • HönöHönö Posts: 64

    I cannot find a key by that name, but I do find HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\F-Secure\My Services Agent\UpgradeRetries. If that is the key to remove, I suppose I still have to reboot my computer after that?

  • HönöHönö Posts: 64

    No matter how much I would like to tag this problem resolved, it is not. After removing the key I found, I still keep getting the reboot pop-up.

  • HönöHönö Posts: 64

    This is only getting worse. I tried uninstalling via Windows Control Panel, but it didn't seem to fully get rid on F-Secure so I ran UninstallTool.exe, and then launched the Network Installer. Now, the installer does not accept my valid Tilauskoodi (subscription code or whatever). So I cannot reinstall F-Secure Internet Security back on my computer!

  • HönöHönö Posts: 64

    I have been processing this with support, and now support tells me that I have "Rapid Boot" on my computer and that I have to uninstall it. But I have uninstalled two sw packages with "Rapid" in their names within a month from purchasing this computer, over two years ago. These were "RapidBoot HDD Accelerator" and "RapidBoot Shield" (they come with Lenovo computers).


    I am working on this with support, but wanted to also check on this forum if anyone else has had experiences with this kind of case? I cannot find anything "Rapid" in Control Panel, so I cannot uninstall "Rapid Boot" as suggested. What else should I try to remove to completely get rid of this bit bloatware?

  • BenBen Posts: 2,641 F-Secure Product Expert

    Rapidboot might indeed create compatibility issues with our software.

    Here is an example with our corporate product.

  • HönöHönö Posts: 64

    Well, turns out support had been hasty in reading the diagnostics. Since I uninstalled the rapid stuff, none is installed. In the end, I had to run fsregfix.exe and then installation succeeded. In my mind, the installer that is too sensitive in this way is faulty.

This discussion has been closed.