Cannot renew F-Secure SAFE

I'm being prompted to renew F-Secure SAFE Internet Security. When I enter my email address and password and click Login, they are cleared and I cannot proceed past the Login screen. I haven't forgotten my password. Despite this, I've tried clicking "Forgotten your password?" When I enter my email address and click Submit, the screen returns "Something went wrong". I've tried telephoning 02088223632 and answer message says they are closed, but does not say when they are open. I've logged into the Chat link, but they too are closed. I need to renew my subscription before F-Secure SAFE expires and I don't know how to proceed. Hope someone can advise. Thanks.

Accepted Answer


  • UkkoUkko Posts: 3,218 Superuser



    Sorry for my reply. Just your descriptions looks like "cookies trouble" or something same.


    For example, which browser you trying to use during login?! And can it's be.. that your browser's settings with hard policy about cookies!? Such as "block all" or "high"-level (for Internet Explorer; with another browsers.. probably there can be just... "block all"); For Internet Explorer... enough "level" before "high" (such as enough high.. and with blocking for third-party cookies)....  with current settings.. login page should be work (include recovery-mechanism).


    But.. if it's not your situation....  can it's be that you have something as NoScript or AdBlock or something other... which can to block some of resources (which can be same with cookies-blocking) during visit F-Secure SAFE Login page?


    Anyway... on current time... I can to think.. that someting about "allow cookies" for F-Secure website should be work for you. And your description-trouble-point can be reproduce with next steps:


    - > Anyone can to open Internet Explorer - re-check settings for "block all cookies" under Privacy settings of Internet Explorer.

    - > Trying to login and trying to recover password - will be same "result", which you noted there.


    Sorry if your situation not about it. And allow-status for cookies or disabled something as NoScript (?!)... or just trying to use Internet Explorer with settings about "cookies" around normal/not so high... will be not work for you Smiley Sad .

    But looks like... that current steps can be helpful there.

    Also... after re-changes with settings.. can be required to re-start browser and trying to do something.


    Sorry again.




    Little addition after that:


    "Potentially"... also... there maybe can be trouble around javascript-settings (such as.. with mobile devices as example.. or browsers, where available to block javascript). But not likely.

  • BenBen Posts: 2,641 F-Secure Product Expert

    Hello MPW,


    If you are still experiencing the problem and couldn't get hold of our support, please check this page.

    You can also contact us through the webform.


    Note that the number you tried to use is only valid for weekdays(Mon-Fri 9-18).


  • MPWMPW Posts: 5

    Hello Ukko

    Thank you for taking the time to provide such a detailed reply.

    Changing browser solved the problem.

    Best wishes,


  • MPWMPW Posts: 5

    Many thanks Simon for a surprisingly simple and effective solution.

    Best wishes,


  • MPWMPW Posts: 5

    Hello Ben

    Thank you for all the information, which was helpful.

    Best wishes,


  • SimonSimon Posts: 2,661 Superuser

    @MPW wrote:

    Many thanks Simon for a surprisingly simple and effective solution.

    Best wishes,


    Thanks for letting us know.  :)

This discussion has been closed.