Freedome works unreliable on iPhone 5S

Kalle123 Posts: 4 Explorer



I have been using freedome on my iPhone 5s and on my iPad mini (first generation). Both on latest SW versions. on ipad this works like a dream but on iPhone it has issues almost all the time to establish connection. Either it does not start automaticly and then when opening the freedom app it checks for a long time, sometimes (but seldom) giving an error that no access to VPN, in most cases no error message or anything, the service just doesn't start and I can't browse the internet until I turn it off, sometimes not even then.


Any tips and tricks here?


  • Ben
    Ben Posts: 2,020 F-Secure Product Expert

    Hello Kalle123,


    Which iOS version are you running on your iPhone?

    Also do these connection issues occur on every location or a specific one?


    Finally, you can refer to this article dealing with similar kind of problem.


  • Kalle123
    Kalle123 Posts: 4 Explorer



    the version of IOS is 8.1.3, I removed and reinstalled the software, I will test whether this will help with this.



  • Moctezuma
    Moctezuma Posts: 2 New Member

    I have the same problem. Since moving to IOS8 (IOS8.1.3) the VPN does'nt connect properly. I have reinstalled Fsecure and VPN several times. Nothing works except shutting IOS and reopen it. Terrible. If no solution is provided rapidly I sould disconnect Fsecure. I am in switzerland my provider is swisscom.

  • Kalle123
    Kalle123 Posts: 4 Explorer



    for me the reinstallation improved the situation, but every now and then still the solution kind of "freezes" and restart of phone is needed to enable freedome to work (or even have any network connectivity from iPhone)

  • Moctezuma
    Moctezuma Posts: 2 New Member
    The solution in the related article doesn't work!!!
    Any fix soon???
  • Setanta
    Setanta Posts: 1

    I'm experiencing the same issues as kalle123 and Moctezuma - Freedome freezes and prevents my phone from connecting to the Internet even when I shut down the app.

    I tried to resolve the problems by doing the same things the other commenters have tried and none of it has fixed the problem.

    The freezes have increased in frequency during the last 7 days (freezes are happening 3-4 times a day for me at the moment) and only restarting my iPhone 5 unfreezes things and allows my phone to connect to the Internet again (and Freedome to start working again).

    Can you please advise if a fix will be forthcoming soon?
  • jo-el
    jo-el Posts: 4 Observer



    have to say that I have exactly the same troubles with freezing Freedome and the problem seems to get even more frequent. My iPhone 6plus needs to be restarted on daily basis. It is not acceptable.

    Furthermore ( maybe belongs to another discussion ), I simply can not connect to foreign web-pages, e.g. Netflix US or any other country, I am always redirected to local version. What could be the reason ?

  • Tapsa
    Tapsa Posts: 82 F-Secure Employee



    There is an underlying bug in the iOS 8 operating system which causes this network disconnection when there is a VPN app like Freedome running on the device. We have hoped that Apple would fix this quickly but at least with the latest iOS releases the problem is still there. 


    We cannot directly affect this in any way, as the bug is in the VPN functionality in iOS 8, but we are trying now again to create a workaround so that this bug would not get triggered, or at least the effects of it wouldn't be this severe. We have some ideas how it possibly could be done but as of now, we don't yet have an estimate when we'd have this workaround ready. 

  • Kalle123
    Kalle123 Posts: 4 Explorer

    hi, does the 8.2 update, launched this week (for Apple Watch mainly) fix this issue?

This discussion has been closed.
Product & Pricing Info