Can`t use Freedom due to problems with IPv6

Hi.
After installing Freedom, I tried to connect but I get a message that says that Freedom can`t connect due to problems with IPv6. It says that my IPv6 is not enabled, but I`ve checked all the places I know of in my computer that it is enabled. What is wrong? How can I solve this? I have Windows 8.1, and I have added freedom to the "whitelist" in my Bitdefender Security.

The error message is as follow: "Your encrypted VPN connection cannot be created because of issues with network configuration (netsh.exe fails). Please check that you have IPv6 traffic enabled."

I have checked that it is enabled (I have checked all the places I know of in the computer).
Can you please help me?

Best Answer

Comments

  • Thank you so much. This solved the problem Smiley Happy
    Thank you, now it works just fine Smiley Happy

  • Hi,

    I get this IPv6 error message as well, and I have tried your solutions -- but there are no "DisabledComponents of type DWORD" in the HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\TCPIP6\Parameters, and therefore no values to change. My Freedome has not been working for a month or so due to this problem. Please, is there a third way of solving this (e.g. reinstalling the former version, which was working properly; everything started with the new version)?

    Hopeful ...

    Teq_77
  • Teq_77Teq_77 Posts: 3
    To fix this, edit the Windows Registry with the standard Windows registry editor REGEDIT.EXE.
    Click the Start button.
    In the search box, type in regedit.exe, and press Enter.
    Expand HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\TCPIP6\Parameters.
    If it has DisabledComponents of type DWORD and value ff, then your TCPIP6 is disabled. Change value to 0 to enable IPv6.
    After changing this, reboot the computer for the setting to take effect.

    Did you EXPAND the regkey? (click on it, then the key will show under and there you can see if it says DWORD and ff)
    helena73p
  • acgacg Posts: 7

    i have same problem and i cant use freedome. i did everything http://community.f-secure.com/t5/F-Secure/ERROR-please-check-that-you-have/m-p/68763/highlight/true#M1133 and dindt fix it

    helena73p
  • Thank you, acg, I will try everything you tried to see if it might work out for me, I will come back to tell. It is such a pity not to be able to use Freedome! I have been using it for my mobile devices for almost a year, and I was very happy to find a version for my computer as well ... and now it's not working ...

  • Yes I did. There wasn't anything called DisabledComponents. I actually even created such a file (which was an advice for an older version of windows) and put the value 0 in it. Doesn't work.
  • TehfcaeTehfcae Posts: 107

    Try the following steps:

     

    1. Click start

    2. Type My PC (may also be listed as "my computer" or "this pc")

    3. Right click what is listed.

    4. Select "Manage"

    5. Go to the device manager.

    6. Under "Network Adapters" find your wireless driver.

    7. Right click your driver and select "update driver software"

    8. Then select Services from the left sidebar.

    9. Right click and restart the following services:

           DHCP client

           DNS Client

           WLAN Autoconfig

     

    Once those have restarted open command prompt as an administrator and type the following commands:

    1. ipconfig /flushdns

    2. netsh winsock reset

    3. netsh int ipv6 reset

     

     

    You may also want to open the task manager and end the following tasks:

    1. F-secure Freedome (in Apps section)

    2. F-secure Freedome Agent (background processess)

    3. F-secure Freedome Service (background processess)

    4. OpenVPN Deamon (background processess)

     

    Then restart the machine. 

     

    Most of that process is redudant but it essiantially resets your computer's internet connection, including connection services, drivers, and stored cache

     

    You can also try to rename "FreedomeVPNConnection" from "Control Panel\Network and Internet\Network Connections" to for example "FreedomeVPNConnection2".

     

     

    Ukkohelena73p
  • TehfcaeTehfcae Posts: 107

    If that doesn't work be sure to make sure you have IPV6 enabled in your adapter settings.

     

    1. Open the Network and sharing center.

    2. Go to Change adapter settings.

    3. Right click the Freedome adapter.

    4. Select properties.

    5. Make sure Internet protocal version 6 (TCP/IPV6) is checked.

    Ukkohelena73p

  • @Tehfcae wrote:

    If that doesn't work be sure to make sure you have IPV6 enabled in your adapter settings.

     

    1. Open the Network and sharing center.

    2. Go to Change adapter settings.

    3. Right click the Freedome adapter.

    4. Select properties.

    5. Make sure Internet protocal version 6 (TCP/IPV6) is checked.


     

    Thank you Tehfcae ! You might have helped me :-D I tried some of the things you suggested (i.e. what I could find in Windows 8.1), and finally I reinstalled Freedome. I can't say what solved the problem, but Freedome is finally running again! Bliss!

    Ukko
This discussion has been closed.