Last build of Windows 10 Tech Preview 9926 has removed F-Secure

Problem with the latest update Build 9926 : F-Secure has disappeared from the computer. It was fine with the previous build, and now it is no longer present in the notifications, or the Start menu All programs. As far as I can tell, no F-Secure process in the Task Manager.



The program seems still present in the C:\Program file(x86) folder but I am not sure what is actually there.


The security center has changed as well, and no longer seems to look for an antivirus software.


  • Tahvo
    Tahvo Posts: 45 Explorer

    Same happened to me just unnistall it and then reinstall the program. It seems to work now. There is alot of issues in the newest preview build in windows 10

  • It is much worse than that. The program has been removed from the list of installed programs so it cannot be uninstalled. 


    I downloaded the removal tool and removed F-Secure Internet Security 2014 manually.


    But when I try to reinstall, the installer goes "Installer integrity cannot be verified". 

    This is really getting frustrating. 


  • Ville
    Ville Posts: 642 F-Secure Employee

    @MitchBoo wrote:


    But when I try to reinstall, the installer goes "Installer integrity cannot be verified". 

    This is really getting frustrating. 




    Please create a bug report in and attach support tool output ( You will have to use standalone support tool, there is a link to that at the beta site under resources.


    We had a few cases where suddenly Windows 10 claims our installer package is not a valid installer, but it never happened to beta version yet. So I'm interested to see what was the problem you had.



    (F-Secure R&D)



    F-Secure R&D, Desktop products

  • Same issue here, also installed the Windows 10 preview en there is no way to install F-Secure IS again. Quiet annoying when paid for a license. I tried to send in a bugreport at the F-secure beta site, but that seems to be a dead end.................. F-secure, please help us.

  • Since Windows 10 is only in tech preview, I can understand F-Secure not really been able to address the situation. Especially if they cannot reproduce the bug in their labs.


    However, the problem seems to be within the F-Secure system of download and the way it checks on the integrity of the executable. The sad thing is because of that pesky download system, there is no way apparently for a user to get the complete installer on his disk manually, as it was the case when I started using F-Secure.


    How difficult is it to provide users in their account space with a link where they can download an installer that works like a disk executable ? 


    One thing is for sure : when Windows 10 comes to market, F-Secure better find another answer than to request remote access to proprietary machines. To see what ? The same as what a screen movie can show ? A dismal failure of an ill conceived delivery system ?


    Otherwise, I do not see how I would keep buying from them. I appreciate very little paying for a license I cannot install.

  • AadK
    AadK Posts: 2
    Same thing happened to me.Twice.
    I cantacted the F-Secure on Fb but the where not aware of any problems.
    Then i chat with F-Secure and they told me to contact XS4ALL in my case.
    Then Xs4ALL had to contact F-Secure about the problem.
    So,we wait and see.
  • AadK
    AadK Posts: 2
    I tried to turn-off the Firewall and installing F-Secure again.
    IT WORKED for me.
    Now i'm safe.
  • Sonera Tietoturva (F-Secure Interent Security) on windows 10 at my PC. and Latest Build of Win10 legally availeble is 10041.
This discussion has been closed.