Frequent disconnects when Freedome active

Freedome / Android 4.4.4 (Cyanogenmod) / Oneplus One

 

I thought my phone was faulty. Internet connection was dropped for about 30 seconds every now and then. For example, 40 minute ride to work, 4-5 disconnects at same locations, where 4G network strength was low.

 

A few days ago there was a problem updating Freedome on Android. Trying to solve the problem, I uninstalled Freedome. Next day no disconnects.

 

After I reinstalled Freedome, problems started again. I tried switching off Freedome - problems disappeared.

 

I cannot figure this out.  Phone handles the connection to 4G/3G network.  Why should using Freedome disrupt data connection when network signal is weak?

 

Network operator is Elisa in Finland.

Comments

  • Same exact problem here.

    Samsung Galaxy S3 (i9300) running Cyanogenmod 11 M12 (android 4.4.4).

    Operator Saunalahti, 3G

  • Same exact problem here.

     

    Device:

    Samsung Galaxy S3 (i9300)

     

    OS:

    CM11 M12 (android 4.4.4)

     

    Operator:

    Saunalahti (Elisa), 3G

  • BenBen Posts: 2,641 F-Secure Product Expert

    Hello Treenox,

     

    Freedome currently may need to reconnect to VPN after 3G/4G disconnects. This should not take more than a few seconds each time though. However, depending on firmware, Android may keep old TCP sessions alive until they timeout. The 30 seconds connection drop you observed  could be partly from that. Could you provide the log files to see if there's something unusual about the reconnects(I'll send you a private message on that)?

     

    We are already working on an improvement which should eliminate the need to reconnect to VPN on 3G/4G connection drops.

     

    Also note that we don't try to prevent using Freedome on alternative ROMs. But it's not officially supported as we're not testing on them and cannot guaranty their functioning.

This discussion has been closed.