Freedome WinPC update 1.0.582.0 fails to install

Hi! Freedome WinPC showed a popup to download and install a new update ver 1.0.582.0 but after awhile a new popup appeared and it reads "Update signature check failed". I tried to update it a couple of times but this happens every time. Then I downloaded the new beta from the link in the Freedome newsletter and it went alright.

 

-Jani

Accepted Answer

Comments

  • NKTNKT Posts: 15 Explorer

    Basically, to ensure the integrity of the downloaded software update, the computers do checksumming, hashing and other checks. If the results don't tally with what they expect, then they will fail the install on purpose.

     

    Imagine if someone saw you using a clever VPN that stopped them spying on your traffic. Wouldn't it be a clever trick to wait until there was an update for it, then insert their tampered file in your datastream, to remove your VPN protection? Well, that's what the checks are there for.

     

    Of course, it's more likely an error, but since it's working now, all is likely well. It only takes a difference of a single bit to trigger this, after all.

    Enfcmedic384
  • Yes, it is really good that there are data integrity checks in the Freedome update process but I suppose there was some kind of a failure in that update file because this problem occurred in two different PCs. And yes I got it updated after all and Freedome is working ok now but I just reported the problem here if the Freedome team would be interested about it:)

    kailash
  • Hi Tapio,

     

    Yes, I had a little suspicion that you might have put that failure there on purpose Smiley Wink Thanks for info, great to be of help! Keep up the good work and Happy New Year!

     

    -Jani

  • axel99axel99 Posts: 16

    I got today, 23th march 2015,  as for quite some time the popup:

    New update available

     

    We have an update version of Freedome for you to install (1.0.850.0) Do you want to download and install it automatically now.

     

    It does not install or download that exe, but instead complains about invalid certificate. I get shown the manual installation URL next:

    https://freedome-beta-updates.fd.f-secure.com/Production/FreedomeUpdate.exe

     

    That link will give me a page with this message on Chrome:

     

    Your connection is not private

     

    Attackers might be trying to steal your information from freedome-beta-updates.fd.f-secure.com etc.

     

    What is going on?

     

     

     

  • BenBen Posts: 2,641 F-Secure Product Expert

    Hello Axel99,

     

    Thank you for the report. We will be looking at the site certificate.

     

    The actual .exe file should be valid and properly signed.

    You can confirm it by right-clicking the file and verify that it is signed by us.

     

  • Just received an update beta notice this early morning. Then when selecting the update link this error/warning message.

    https://freedome-beta-updates.fd.f-

    secure.com/Production/FreedomeUpdate.exe

    Your connection is not private

    Attackers might be trying to steal your information from freedome-beta-updates.fd.f-secure.com (for example, passwords, messages, or credit cards).

    NET::ERR_CERT_AUTHORITY_INVALID
    Back to safetyHide advanced

    This server could not prove that it is freedome-beta-
    updates.fd.f-secure.com; its security certificate is not
    trusted by your computer's operating system. This may be caused by a misconfiguration or an attacker intercepting your connection.

    Proceed to freedome-beta-updates.fd.f-secure.com (unsafe)
  • Seems HTTPS was compromised while trying to download.

     

    Looking at the connection and download/transfer information was at a crawl and upload data was massive.  Any thought about an attempt to upload my data without permission?

     

    Current Connections (Standard)
    prot
    local
    remote
    program
    l7_prot
    tx
    rx
    tx/s
    rx/s
    time
    rtt
    class
    tcp 198.18.18.250:49623 5.10.111.221:443 chrome.exe SSL_C 26031 1495K 373 23268 1m 8s 1483 higher
    tcp 198.18.18.250:49582 72.21.91.97:443 chrome.exe SSL_C 8993 202K 0 0 3m 29s 279 higher
    tcp [fc00:fed0:0:1002::10bd]:49310 [2607:f8b0:4001:c1b::bc]:5228 chrome.exe SSL_SPDY_C 3305 7736 0 0 20m 25s 84 higher
    tcp 198.18.18.250:49625 162.246.167.197:80 fsorsp.exe HTTP_C 473 685 0 0 52.525s 45 idle
    udp 198.18.18.250:889 198.18.18.251:889 spd.exe Unknown 2896 0 1351 0 13.509s - higher

  • I completed the manual download of the freedome update today (4/20/2015)  after the automatic download failed. Now freedome will not restart or run on my computer.

     

    This is VERY problematic. I am traveling on business and will not get back home for several days. I need my laptop functioning NOW and I need it to operate securely at all times. That is why I purchased the product.

     

    How can I get Freedome back in an operational mode IMMEDIATELY on my laptop over an unsecured network?

     

    Frankly, as a business professional, I was flabbergasted to read a reply post that interpreted the certificate error blunder as a good thing.  It was NOT. I need to work on my client's  project but I am now spending my time trying to get my computer back into a secure mode.

  • Was finally able to secure a HTTPS/ connection to download (Manually) the updated beta version.  Install was not an issue and ran fine.

     

     

  • yeoldfartyeoldfart Posts: 512 Superuser

    same symptoms with latest version: fails to reinstall with error 7 on Windows 10, worked like a charm till today

This discussion has been closed.