Troubleshooting Windows version of Freedome?

 

I received the beta link today and installed the application successfully. However, I can't successfully connect to any of the servers available.

 

Any suggestions on where to look?

 

Thx!

Best Answer

  • okjayjayokjayjay Posts: 3
    Accepted Answer

    Reinstall of the application seemed to work!

     

    The Espoo, FI connection is very slow but hopping around has provided some faster options.

Answers

  • BenBen Posts: 2,640

    Hello Okjayjay,

     

    Could try to connect through the same network with for example Freedome on a mobile device?

    Also do you know if VPN's are usable on your network?

     

  • Hi Ben,

     

    Yes, I am connected to several IPSec VPNs with various different end points on this network. Freedome BETA successfully connects without issue on Android devices on the same network. 

     

    I was able to get the IP of the end point from the Android version & verify the Windows machine is talking outbound to it via traffic capture. I don't see anything obvious to indicate the issue though.

  • Hello!

     

    I am having the same problem (I suppose). I tried to turn the Freedome PC Beta on, and the button turned back to OFF after trying to connect. Re-installing didn't do the job. Freedome works on iOS device using the same network. So it is a software related problem? Please send help. I want to watch BBC online from Finland Smiley Very Happy

     

    freedomePCbetaBUG.PNG

  • A third re-instal and reboting the computer got it working.
  • rajaraja Posts: 1

    @F-Secured wrote:

    Hello!

     

    I am having the same problem (I suppose). I tried to turn the Freedome PC Beta on, and the button turned back to OFF after trying to connect. Re-installing didn't do the job. Freedome works on iOS device using the same network. So it is a software related problem? Please send help. I want to watch BBC online from Finland Smiley Very Happy

     

    freedomePCbetaBUG.PNG


     

  • TehfcaeTehfcae Posts: 107

    Make sure you have IPV6 enabled in your adapter settings.

     

    1. Open the Network and sharing center.

    2. Go to Change adapter settings.

    3. Right click the Freedome adapter.

    4. Select properties.

    5. Make sure Internet protocal version 6 (TCP/IPV6) is checked.

     

    After that you can try the following steps:

     

    1. Click start

    2. Type My PC (may also be listed as "my computer" or "this pc")

    3. Right click what is listed.

    4. Select "Manage"

    5. Go to the device manager.

    6. Under "Network Adapters" find your wireless driver.

    7. Right click your driver and select "update driver software"

    8. Then select Services from the left sidebar.

    9. Right click and restart the following services:

           DHCP client

           DNS Client

           WLAN Autoconfig

     

    Once those have restarted open command prompt as an administrator and type the following commands:

    1. ipconfig /flushdns

    2. netsh winsock reset

    3. netsh int ipv6 reset

     

     

    You may also want to open the task manager and end the following tasks:

    1. F-secure Freedome (in Apps section)

    2. F-secure Freedome Agent (background processess)

    3. F-secure Freedome Service (background processess)

    4. OpenVPN Deamon (background processess)

     

    Then restart the machine. 

     

    Most of that process is redudant but it essiantially resets your computer's internet connection, including connection services, drivers, and stored cache

     

    You can also try to rename "FreedomeVPNConnection" from "Control Panel\Network and Internet\Network Connections" to for example "FreedomeVPNConnection2".

     

This discussion has been closed.