F-secure is acting bad !!!!

For the last couple of days, I am finding that F-secure has been bogging down my PC and giving me grief.  I first noticed it when I downloaded a few patches for The witcher.  After downloading these patches, F-secure would make the folder, where I had downloaded these patches in, unresponsive.  It would take up half of my CPU(50%) and computer would get laggy.  My solution was to disconnect from the internet and shut off F-secure.  Everything went back to normal.  After I installed the patches I turned F-secure back on.  That's when I discovered I could no longer access the internet.  I had a connection but I couldn't get firfox to run or windowslive or any other app for that matter.  I reset my PC and everything was back as it should.  Anyway, I start up the witcher and nothing happens.  Hmmm.  I look in task manager and find that the exe. Is running.  I attempt to close it and nothing happens.  So I restart my PC and and again disconnect from the internet and shut down f-secure. I run witcher and it runs.  Yesterday I installed Battle for middle earth and when I attempt to play it, again it won't run.  I don't get a warning or a permission from F-secure asking if its OK to run this prog.  To fix this problem I went int F-secure settings/virus and spyware scanner and changed the option from always ask me, to, if unclear, ask me.  I changed deep guard to the same and now BFME runs fine, like it should.  I haven't had to change anything in fissure since i installed it.  I almost always got a permission when I ran a program for the first time but for the last few days it doesn't even ask if the newly installed programs are allowed internet access.  I run Windowsxp service pack 3 on a p4 3.0 with 4gigs 3200ram.  I am hoping that there is a simple solution because I use my pc at least 4 hours per day.  Any thoughts or suggestions would be very appreciative.

 

Techie

Drake

vevomack

Accepted Answer

Comments

This discussion has been closed.