iOS 8 users: Do NOT upgrade to Freedome 2.0.1

TapsaTapsa Posts: 77 F-Secure Employee
We just released version 2.0.1 of the F-Secure Freedome VPN for iOS to App Store.

If you're running iOS 8, please do not upgrade to Freedome 2.0.1. If you have already upgraded, please do NOT launch our app and click the "Protection On" button. The old VPN profiles still work if you don't do this. This bug does not concern iOS 7 users.

If you've already started Freedome 2.0.1 on iOS 8 and tried to turn protection on, Freedome VPN will not work. There will be no VPN icon in the top bar of the screen. You'll see a message saying "Error initiating VPN connection" when you try to open the Freedome VPN user interface. The only solution in this case is to wait for the new version of Freedome VPN.

We have a fix. However, as Apple reviews all the apps they publish in their store, there will be some delay before the fixed version is available. We'll keep you posted on the process.

We are very sorry for the inconvenience.

This bug was not detected until the App Store release, the internal test version did not have the bug and Apple's process doesn’t allow any way to test the actual to-be-released App Store version. 
Ukko

Best Answer

  • TapsaTapsa Posts: 77 F-Secure Employee
    Accepted Answer

    Good news! Apple has reviewed and approved F-Secure Freedome VPN 2.0.2. It includes fix to this iOS 8 issue. The version is currently being distributed to the App Stores and is already available in many locations.

     

    You can get this version by opening the App Store on your iPhone or iPad and going to the Updates section. If you cannot see Freedome 2.0.2 there yet, just try again a bit later. 

     

    Thank you for your patience with this problem. We will try our best to avoid this kind of issues in the future.

    ChrissyUkkoMiho
«1

Comments

  • StooStoo Posts: 13

    EGADS!!!!!!!!!

    I wish I would've noticed this post sooner. I now have to wait for the next update.

    Sadness  :-(

  • Same here Smiley Sad
  • TapsaTapsa Posts: 77 F-Secure Employee

    This was quite an unfortunate incident and we're very sorry about it.

     

    We have not yet received a confirmation from Apple when the fixed version is going to be reviewed. As soon as we know more, we'll let you know.

    UkkoStoo
  • MihoMiho Posts: 16
    Can the new fix solve the profile installation as well?
    Because of the problems, I have deleted the profile and I cannot re-install it anymore...
  • StooStoo Posts: 13

    Computers, software and ESPECIALLY humans are not perfect, so mistakes can and WILL happen. Freedome is still the best VPN (in my humble opinion) software around, so it's well worth the wait. Smiley Happy

    Chrissy
  • TapsaTapsa Posts: 77 F-Secure Employee

    Hi,

     

    Yes, the new version will handle the profile installation. 

     

    And thank you for the kind words. Mistakes do happen to everyone - it is just sad that in this case our users have to suffer because of this mistake. But hopefully the review goes through quickly and you all will receive a fully working version of Freedome soon.

     

    UkkoStooMiho
  • gkkigkki Posts: 1

    "(...) the internal test version did not have the bug and Apple's process doesn’t allow any way to test the actual to-be-released App Store version"

     

    Why does this happen with Apple store? The developer has to submit the full codebase and apple builds the binary from the codebase, and distributes that binary to in its Store? I'd really like to know some info behind this.

    Ukko
  • Great news, thank you :) it was not too hard to wait this short time it took...

    I have also been very happy about the product and used it ...
    Great work !


    Tomi
  • MihoMiho Posts: 16

    Thank you for the update!

    This is why I only use F-Secure productsSmiley Wink

  • RelexRelex Posts: 12
    This morning After update 2.0.2 ... All set .... Smooth operating ... Great update ... Txs
  • StooStoo Posts: 13

    Excellent!!!

    That was super fast. Thanks for the hard work, folks.

    Freedome RULES!!!

  • RelexRelex Posts: 12
    Thought problems were solved after this mornings update. 2.0.2
    But right now freedome VPN is switching of constantly. So have to switch it on manually constantly.
    Also the freedome VPN profile is unsigned.
    So still some bugs in there !!
    Ukkounderthewhip
  • BenBen Posts: 2,640

    We already received reports of this with the latest version and are already working on it.

    We'll update you on that as soon as possible.

  • RelexRelex Posts: 12
    Thanks
  • Great product... except ... In iPhone 6 plus VPN stays on only a while and then shuts down. Are you planning to release a quick update also for this one?

    Freedome has been extremely reliable on my previous Android phone and now I'm really disappointed how it works with iOS. Well I suppose I should had stayed with my Sony Z2 .
  • BenBen Posts: 2,640

    @Relex here is some clarification on the unsigned profile in use.

     

    We are still investigating the ongoing issue with the latest version.

  • RelexRelex Posts: 12
    Txs for your feedback Ben. Seems IOS 8 is causing a lot of headaches for lots of App developers. Hope fix for freedome will release soon.
  • How do I find the information on the version of Freedome in use in my iPhone5?

  • BenBen Posts: 2,640

    You can find the version of Freedome installed on your device by going in the "About" section.

  • RelexRelex Posts: 12
    Is there already a fix for VPN repeating cutting of spontaniously after installing last update 2.0.2. No more feedback received on this topic since my last post and answer from Ben that you were looking into this subject.
  • Same problem here. After installing 2.0.2, VPN automatically shuts down after a while, no stable connection possible. Extremely bothering.
  • RelexRelex Posts: 12
    I absolutely agree ... Especialy when I read the post from the helpdesk on the forum that problems on update are solved
  • Pheww. I'm happy I'm the only one this problem and I expect this issue (vpn shutting down) to be solved soon.
  • I meant. I'm NOT the only one with the problem.
  • TapsaTapsa Posts: 77 F-Secure Employee

    We have F-Secure Freedome VPN version 2.0.4 submitted to the Apple review process. As soon as Apple approves it, we will publish it to our users. It includes changes that should solve these connection dropping issues when used with iOS 8.0.2 (which is the latest iOS 8 release at the time of writing this). 

     

    BenUkkoMiho
  • Thx Tapsa, looking forward to this release and hoping that this will solve the connection issues.

  • RelexRelex Posts: 12
    Txs Tapsa, looking forward and hope all problems solved after this new release ...
  • I have the same problem. Looking forward for the fix.

  • I have the same problem with both iPad Mini (iPad 2.5) and iPod touch, Is there a security risk when the VPN drops off? Is all web traffic visible and unsecure and should we alla discontinue using Freedome until the fix is ready? Little testing would be nice before release....

This discussion has been closed.