FIS 2012 - "Do not ask again" Option not available

Hello,

I'm testing FIS 2012 now. In contrast to the 2011 version, the application control pop-up have no more the "Do not ask again" Option (the checkbox to remember or not the config). Can I reactivate it? I haven't fiound any option to do so.

Thanks in advance

Comments

  • SiltanenSiltanen Posts: 108 Former F-Secure Employee

    Hi drigo,

     

    This is now the default action. Meaning that popus will appear only once per application. It's not possible to get the "old" functionality back.

  • In FIS 2012 I miss the option "ask again" or "allow once" in this Dialog.

    Some programs I'm running usually don't connect to the internet so I want to know when they try to connect to the internet.

    A workaround is to allow this program and then delete the entry but it's not ideal.

     

    But something other bother me: If I see the dialog "Allow connection to the internet" and click escape, the program is allowed to connect to the internet. Is this a bug or dose this bother only me? I use escape to abort an action.

     

    (System: Win7 64-Bit, SP1)

  • drigodrigo Posts: 3

    That's annoying! :-(

    I'll stay on FIS2011 because I need this function.

  • maxatappmaxatapp Posts: 2

    FS 2011 Update change this behavior even on 2011 release !

     

    First of that I did a big use of  "Ask me" function, it's really required when you'd allow an application to get connect to an address and not to another addresses.

     

    For me, it's was an unique feature that did the difference with other security softwares, now FS is the same like all others :/

     

    Some times the commercial policy of a product get over all important features getting rid of technical functions like this.

     

    This is not appreciate!

     

    ---

    max

  • beikerbeiker Posts: 33

    Would reinstalling the whole software help? Only if we really need that functionality. 

  • alconsvralconsvr Posts: 26

    @drigo wrote:

    Hello,

    I'm testing FIS 2012 now. In contrast to the 2011 version, the application control pop-up have no more the "Do not ask again" Option (the checkbox to remember or not the config). Can I reactivate it? I haven't fiound any option to do so.

    Thanks in advance


     

    Why was this feature removed? It should also have an allow once capability, for programs that are neither allowed or blocked.

  • What about FIS2013? Is the option back?

    If not, could you tell me which other internet security offers such "personalization"?

     

    Dear marketing guys from FS,  If you just thinking about noobs and not to frustrate them with a lot of options it's ok. But you can juste hide the option and let it be activable for interesting users.

    Removing this option is a no go!!!

  • RobiRobi Posts: 6

    See: http://community.f-secure.com/t5/Protection-Safe/Changed-settings-in-new-version/m-p/15270

     

    I wrote:

     

    "The application control tool has changed. It now asks me to accept or deny a program to connect to the Internet. Accepting automatically means accepting it for all instances after the first time, which I don't like. I want to be able to allow a program on a per instance decision as it was before. The check-box to always allow a program has gone. But I don't want, for instance, that the Windows Installer can access in the background every time, once I have allowed it for another instance. I want a notification every time a program wants to connect. And I want to be able to decide whether or not a trusted program may connect everytime or not.

    Worse: it automatically means that if you allow, it will allow connection in two directions as a program default. Not sure if the firewall reacts according to this setting. If so, the application control renders the firewall useless, as it will accept both outgoing as well as incoming traffic based on the lack of the option in the new GUI to set your preference. This can't possibly be the case. I want to decide whether a program may connect once, always and, moreover, whether it is allowed to accept incoming, outgoing or both connections."

     

    I now have to go into the settings to manually disable the incoming connection or remove the entry. This is a lot of clicks and it is very annoying.

     

    I can't see why this functionality has been taken out. In my opinion, it's a bad decision.

     

    I bumped the post in this forum, since I didn't get any reply.

  • JaysonJayson Posts: 595

    Hi,

     

    F-Secure Internet Security 2013 will be release soon and the Application Control feature has no longer available in this release.

     

    Thanks.

     


    Best Regards,
    Jayson

  • RobiRobi Posts: 6

    Hi Jayson,

     

    Thanks for the reply. I sent some feedback in my original post.

     

    The lack of this feature will have me switch to another product.

     

    Can you explain why this change is made? How can one determine which programs are cleared for connections? Does this mean that the software will do this automatically? Without notifying the user? Based on which rules?

     

    Isn't it an essential part of any security program to block by default and ask the user to interact? Or at least give the opportunity to opt-in/out?

     

    Robi.

  • I just can't understand it! That is really annoying.

    For now I'm going to look for another Internet Security with a real firewall.

  • Yes, I too!

     

    Then some users talks about Linux and Open Source. **bleep**!

    FS is on the same way of Microzoft, it's only for dummies peoples.

     

    At the end the market will win.

     

  • JaysonJayson Posts: 595

    Hello,

     

    Please find more details about "What has happened to the firewall in F-Secure Internet Security 2013" from the KB article. 

     

    Thanks.


    Best Regards,
    Jayson

This discussion has been closed.