My Installation of F-Secure never "Finishes" on Windows Vista.

I am using Eastlink Internet Security Services which is a re-branded version of F-Secure. The particulars are as follows:

 

EastLink Internet Security Services 9.12 build 112

F-Secure Anti-Virus 9.20 build 15437
F-Secure Automatic Update Agent 8.25 build 4095
F-Secure User Interface 9.10 build 6317
F-Secure Management Agent 8.10 build 30091
F-Secure Parental Control 8.50 build 15461
F-Secure E-mail filtering 1.02 build 7480
F-Secure Network connections 6.24 build 124
F-Secure Email Scanner 6.00 build 435
F-Secure DeepGuard 2.21 build 114
F-Secure Online Help 2.00 build 1470
Customization
F-Secure Sidebar Gadget 1.00 build 192
F-Secure Service News 1.00 build 140
F-Secure Browsing Protection/SW 1.10 build 5646
F-Secure Browsing Protection/ES 1.10 build 1039

 

I have been able to install it on 2 computers running Windows 7 without issue. I tried to install it on a newly re-installed , clean, Windows Vista desktop (the license with Eastlink allows me 3 computers simultanteously) and while it appears to install, scan and update......It always says that the "installation is finishing" in the status section of the launchpad. This is disconcerting and I am wondering if there is a resolution for it.

 

Thanks,

 

Keith

Comments

  • SiltanenSiltanen Posts: 108 Former F-Secure Employee

    Hello Faseeshuss,

     

    Can you check under Downloads that you don't have any downloads with status other than "Installed"? (F-Secure -> Settings -> Other settings -> Downloads)

This discussion has been closed.