PC game Magic 2015 (via Steam) won't launch due to F-Secure internet security




I got error code 51 from steam software when trying to launch the game and seems like I haven't been the only one (although they are complaining about earlier year's version of the game but it's very similar every year):



Launch succeeds after I disable all security features. Please fix!




  • Simon
    Simon Posts: 2,667 Superuser
    This isn't the first time people have had issues with Steam games. I'm not sure that's it's always F-Secure which is the culprit, but firstly, have you tried running the game in Gaming Mode?
  • Matjek
    Matjek Posts: 5 Observer

    No, enabling gaming mode didn't help. Still steam gives error 51 when launching. Also I checked the application permissions from tools menu and the game is not visible there. Only one other steam game is listed there as "allowed" and it has always launched without any problems as have all other games. I didn't yet own f-secure when I played previous magic games so can't say about those



  • Ukko
    Ukko Posts: 3,634 Superuser



    Sorry for next words. Just like random suggestion.


    Potentially you can to try goes to Computer Security - Settings and part about DeepGuard.


    Here you can to check feature about "compatibility mode".


    After that - will try to launch game/steam (?!).


    If all will be good. you not really need to disable F-Secure in full meanings.


    But it's more hard, than use just "gaming mode" , but it can be addition for less resources usage.


    It's mean -> if you trust for any situation during play for current game.

    I can to recommend try next steps:


    -> Re-check DeepGuard settings for "compatibility mode" turn ON.

    -> Turn on Gaming Mode for less resources-usage by F-Secure during game.

     -> Play to game.


    After that -  back protection-feature to high-level :).


    And maybe you can to try use F-Secure SAS (https://analysis.f-secure.com/) - maybe they able to fix something around. Here I mean - if you able to detect... when certainly happened mistake (during which trying to execute, for example).




    Also Steam games can to use a lot of tricks. So.. it's normal that F-Secure not able to normally allowed some of them.

  • Simon
    Simon Posts: 2,667 Superuser
    I second Ukko's suggestion of sending in a sample to the F-Secure Labs, who may be able to whitelist the application. In my previous experience, this is a reasonably quick and painless process.
  • Ukko
    Ukko Posts: 3,634 Superuser

    But I also... think after that..

     If current one situation not really related with any protection-points.

    And here something other (like reason for troubles) -> also you able to create fsdiag (after repeating situation and by Support Tool) and transfer it with description about situation for F-Secure Support (http://www.f-secure.com/en/web/home_global/support/contact/request);


    Of course, if need to get some kind of reaction more speedy, than it can be ..... from current place (which also checked by F-Secure Support team probably).

  • JohannesL
    JohannesL Posts: 38 Former F-Secure Employee

    Hi, Matjek!


    Manuel's post is one solution and a good one, so you should try that one.


    Second solution can be that you go to Computer Security --> Settings --> DeepGuard --> Change application permissions.

    If the game is in the list then make sure that it is allowed you can also add the game to the list and press allow to it and then it should'nt be any problems.


    PS. Make sure to confirm the solution when the problem is solved.

This discussion has been closed.
Pricing & Product Info