Icon in dock on Mac does not open F-Secure for Mac.

I recently renewed F-Secure for Mac but now find that the application does not open from the Application Folder, the icon in the dock, nor from Launchpad.  Surprisingly it does open from the menulet at the top.  Since I always open from the icon in the dock, how can this be fixed?

Accepted Answer

Comments

  • Simon
    Simon Posts: 2,661 Superuser
    I'm hesitant to respond, as, not being a Mac user, I might be barking up completely the wrong tree, but have you tried reinstalling FS?
  • NikK
    NikK Posts: 935 Rock Star

    In case Simon's advice won't help I was going to recommend you to send an FSDIAG file to support, but I just checked my Mac and I can't find an option to create such a file in the Anti-virus for Mac product. And I can't find any information on either the FSDIAG page or the Request Support page that FSDIAG only exist for Windows and not Mac.

     

    Assuming I haven't missed something and this is correct I think F-Secure should add information about that in those pages.

  • Pekko
    Pekko Posts: 40

    Hi Richtex,

     

    please try to remove the installation and reinstall the version for which you have the license again. Best is to use our Uninstallation tool You can find the tool and Readme instructions here: ftp://ftp.f-secure.com/support/tools/uitool/mac/MacProtection/

     

    If after this you still face the issue, collect an FSDiag log file with our standalone tool for Mac. ftp://ftp.f-secure.com/support/tools/fsdiag/mac/ and open a case with our technical support via http://www.f-secure.com/en/web/home_global/support/contact

  • Richtex
    Richtex Posts: 5

    Pekko, thank you for your reply regarding the icon difficulty with F-Secure for Mac. In connection with the problem I had with the renewal of coverage, the support staff uninstalled and reinstalled the application a number of times.  It was after this series of uninstalls and reinstalls that the icon and the Application Folder did not open the application.  Since this procedure has been done numeroous times I would not think another would do anything.  The support staff took control of my machine several times, repaired all permissions, etc.  I am somewhat exhausted at the time spent on this project, but would welcome any easy answer.  For now I will just use the small munulet icon at the top of the screen which does seem to open the application.  Hopefully, nothing about the operations of the software is inoperative.

This discussion has been closed.