Freedome does not work on iPad but does on iPhone

I have been using Freedome without a problem for the past several weeks on my iPad Air and iPhone 5s.


Then, yesterday, Freedome stopped working on my iPad Air.  So, I tried the usual:


1) Power off iPad.  Power on again.  This has always worked in the past.  Not yesterday.


2) Delete profile.  Reinstalling the profile has always worked in the past.  Not yesterday.  Now my profile has disappeared in in my iPad settings, and so it cannot be reinstalled.


3) Delete app.  Reinstall app.  This has worked in the past.  Not yesterday.  Now Freedome crashes instantly at launch, every time.  And my profile is still missing in settings.


4) Delete app.  Power down.  Power on.  Hold down power and home button.  Then reinstall app.  Nope.  Freedome crashes every time at launch.


5) Reset network settings.  Nope.  Freedome still crashes at launch.


6) Empty cookies and cache, etc. in Safari.  Reinstall app.  Freedome still crashes.


I have Javascript on in Safari.  It has never been off.


Please note that Freedome still works correctly on my iPhone, but not on my iPad.


Please help.


  • Bayani
    Bayani Posts: 58 Enthusiast



    When it crashes, does it come up with any kind of error message or does it just freeze at that point?

  • Freedome crashes at launch without a message.


    This started the day Freedome released its latest update.  Apparently the update killed Freedome for iPads while working correctly for the iPhone.

  • Bayani
    Bayani Posts: 58 Enthusiast

    Ok, checking this with our technicians.

    Will get back to you as soon as I get an answer.

  • [Deleted User]
    [Deleted User] Posts: 0 Former F-Secure Employee



    Thank you for notifying us about the problem.


    Would you be able to collect us a log using iPhone Configuration Utility when the crash happens.


    The utility can be downloaded at:

    Windows :
    Mac :


    Here's an image to help collect the logs: 


    You can send the log to:


    Thanks for your help.


    Best regards,

    Päivi, Freedome team

  • [Deleted User]
    [Deleted User] Posts: 0 Former F-Secure Employee

    Hi Wilderness!


    Just wanted to check in and see if you've sent the logs and found a solution to this issue.  If you have, please share what fixed the problem!  If not, we're still here to help :)


    // Chrissy

  • Jrbravo
    Jrbravo Posts: 1

    Hello !!,


    My english is not good enough so here is in spanish...


    Hoy instale el F-Secure freedome en mi Ipad iOS 7.1.2 pero no funciona adecuadamente.


    Al momento de levantar el sitio virtual cancela totalmente la conexion a internet del Ipad, como solucion lo desintale y borre la vpn, probe la conexion a internet y funcionaba.


    Nuevamente como comento anteriormente Wilderness lo reinstale y colocando los parametros (settings) asi como el codigo (david) y todo estaba bien, procedi a realizar la activacion del sitio virtual y mismo problema, cero conexion, no conecta.


    Lo tengo instalado en la Samsung Tab 2 de mi hija y funciona perfectamente pero en el Ipad en lo absoluto.


    Quedo a la espera de sus bien habidos comentarios,


    Jose Bravo

    Caracas Venezuela

  • [Deleted User]
    [Deleted User] Posts: 0 Former F-Secure Employee

    Hola Jose,


    I'm sorry for the delay with the response.


    Did you try if the removal of the Freedome VPN profile from the device settings and putting Freedome back on help? Uninstallation of the app itself is not enough to fix the problem.






  • MX
    MX Posts: 1
    I'm having the same issue. Just installed Freedome for the very first time, wasn't able to open it once. A blueish screen shows for a second, and then the app crashes. Deinstalled, reinstalled, restarted iPad -- nothing helps.

    iPad MC707X/A
    iOS 7.1.2 (11D257)

This discussion has been closed.
Product & Pricing Info