internet security doesn't allow me access to the internet

so i purchased and installed the f-secure internet security for pc, an haven't been able to log on to my favorite sites since then. the program seemed to install just fine, but i can't get online. i can log on to facebook, but i don't see any posts or anything. it won't let me log in to tumblr. in fact, if i didn't have a second computer, i wouldn't be able to write this message. i've been trying to install chrome, big nope there! somebody, anybody HELP ME! i bought this frickin' expensive anti-virus program so that i'd be better protected online. well, it kinda works, since i can't get online.

Best Answer

  • NikKNikK Posts: 931
    Accepted Answer

    @ninnukka 

    I agree with Simon, you shouldn't have to add those programs. I suggest you remove them and see if it indeed was the McAfee Removal Tool that did the trick.

     

    To quote Microsoft: "Allowing a program to communicate though a firewall (sometimes called unblocking) is like punching a hole in the firewall"

     

    In a default Windows Firewall configuration you shouldn't need to allow programs as all outbound connections are allowed by default, and all inbound are blocked. Inbound is rarely needed, only if you for example host a web server locally and must allow internet traffic to it.

Answers

  • SimonSimon Posts: 2,560
    Firstly, did you fully uninstall any previous antivirus products on the computer, using the proper uninstallation tools? If not, this might help:

    http://answers.microsoft.com/en-us/protect/wiki/mse-protect_start/list-of-anti-malware-product-removal-tools/2bcb53f7-7ab4-4ef9-ab3a-6aebfa322f75
  • ninnukkaninnukka Posts: 10

    yup. my whole computer was rebooted, so i only had the free version of macafee, which was removed.

  • NikKNikK Posts: 931

    This is not normal! Try to re-install F-Secure and see if that helps.

     

    If that doesn't help, try disabling the F-Secure add-on in IE: Press Alt+X (or go to the Tools menu) and select "Manage add-ons". Select "F-Secure Online Safety", and click Disable in the bottom right corner. Restart IE and test. Remember to enable it again after testing, if you want this functionality.

     

    Also you can submit a Support Request and attach an FSDIAG file to it so support can check your log files and find out what's causing this.

  • ninnukkaninnukka Posts: 10

    yeah, i decided to try re-installing. we'll see if that helps.

  • SimonSimon Posts: 2,560
    Sorry to push on this, but did you use the Mcafee removal tool to remove it? If not, I would suggest running it, as proper removal of a previous antivirus product can make all the difference.
  • ninnukkaninnukka Posts: 10

    umm, no. the guy at the store told me to use the windows removal-thingamabob, so i used that.

  • ninnukkaninnukka Posts: 10

    it's days like these that make me wish i had someone in my life who's better with computers than i am. Smiley Very Happy

  • ninnukkaninnukka Posts: 10

    yeah, re-installing didn't work. i'm gonna call it quits for today and go to bed.

  • SimonSimon Posts: 2,560
    Well, try running the tool anyway. If there's something still there to remove, it should remove it. If there isn't, it shouldn't do any harm and we can move on. :)
  • ninnukkaninnukka Posts: 10

    the problem with that being that i can't get to the link on the troubled computer... i'm just gonna try again tomorrow, as it's almost midnight here, and i can't think straight. thanks for trying to help. :)

  • SimonSimon Posts: 2,560
    OK, when you're ready you could download the link and transfer it to the troubled computer via a USB stick.
  • UkkoUkko Posts: 2,893

    Hello,

     

    Like addition to potential reason with previous installation/uninstallation of McAfee....

     

    Just because... you able to visit some pages, but some part of websites not work.....

     

    Maybe you can to check F-Secure -> Online Safety -> something around content blocker/category of blocking.

    If you don't modify it after installation and if that place have "turn on"-status by default... maybe here some categories... related with your trouble... and that categories check to "block"?

    For example... forums/blogs/unrated, but it's should be not a default setting. So.. it will be strange if current suggestion will be work :)

     

    Also... I not found version of browser, operation system... but it's can be... if during work with your system... here have some trouble-places or simply Real-time protection Network (service/feature/other by F-Secure or other part about reputation for websites/web-traffic) have "not connected"-status (can be by various reasons and not always can be critical) and during visit any pages (or just HTTPS pages) will be "troubles". But it's should be just some versions of browsers. They should be some kind of outdate... 

     

    Also... does you mean... that installed F-Secure Interet Security 2014? :)

  • ninnukkaninnukka Posts: 10

    i got it to work! yay, me! Smiley Very Happy the problem was with the firewall, so once i got that fixed, i'm good to go. thanks for the help!

  • SimonSimon Posts: 2,560
    So, for the benefit of others, what did you do to solve it?
  • ninnukkaninnukka Posts: 10

    i went to online security > tools > windows firewall > and chose explorer and chrome as programs that are allowed access thru the firewall. and that solved my problem!

     

    oh, i also ran the mcafee removal link you gave me, just in case. so thanks for that!

  • SimonSimon Posts: 2,560

    OK, that's rather odd, as you shouldn't have had to do that (IE and Chrome should have access enabled by default), but perhaps McAfee changed some of the settings, which may have 'stuck' if it hadn't been fully removed.  

  • ninnukkaninnukka Posts: 10

    okay, so i tried removing them, and allowed access to a program or two that didn't have access (i checked on the old computer which programs have access on it). it looks like it still works.

This discussion has been closed.