Freedome not connecting after upgrade from JB 4.3 to KitKat 4.4

I have a stock Dell Venue 8 android tablet that came with JB 4.3, and I have been using Freedome (with paid subscription) on it for the last 2 weeks.  I have had no issues at all, until yesterday when I upgraded with the Dell Venue KitKat 4.4 update.  Now I can launch the application, but when I try to connect now (touch the "Connection off" circle, check the "I trust this application" and press "OK"), it says "Connecting..." for about 1 second then goes back to "Protection OFF" without giving any errors or messages.

I have tried the folowing:

Settings->Apps->Freedome->Clear cache

Settings->Apps->Freedome->Clear data

Uninstall the app, then got to the Play store and redownload and install

Power off the device completely, then power back on


I use the Junos Pulse VPN app to connect to my work via VPN, and that is working just fine.


Is there an issue with Freedome on KitKat?  Thanks for any help.


  • Ben
    Ben Posts: 2,020 F-Secure Product Expert

    Hello Perelandra,


    There shouldn't be issue with KitKat, as F-Secure Freedome supports Android 4.0.3 and later.


    Do you use a specific power saving mode? What kind of network are you trying to connect from? 

  • Jayson
    Jayson Posts: 490 F-Secure Product Expert

    Hello Perelandra,


    Could you please try connect to a wifi(wireless LAN) then switch ON the F-Secure Freedome? I believe it should be working fine if I got this one right.



    Best Regards,

  • Perelandra
    Perelandra Posts: 4

    Hi Jayson,

    So far I have partial success in getting this working.


    Yes I am connected to Wifi, I have tried Freedome both at home on a DSL wireless router and on my work wifi.  Since my first post I have tried the Android system recovery to get a clean install of KitKat.  I did the "wipe cache partition" first, then the "wipe data/factory reset".  When I entered my googe account info after the factory reset, I choose to not enable automatic updating from the google backup so I have a clean system.  I then went to the Play store, downloaded Freedome, and accepted all the agreements.  It still would not connect, just tries for a second, then goes back to "Protection Off".


    Then I created a new user account on the tablet.  I set that account up with the same google account as the owner account and installed Freedome.  Freedome will connect under this new user account I created, but it will not work under the original owner account.  I have tried clearing all Freedome cache and data again under the owner account but still it will not work.


    I also did another factory reset, this time allowing the owner account to restore all app settings from Google backup.  And I created a new user account again.  I get the same results with Freedome not working in the owner account, but it does work in the user account.


    So my current status is:

    Owner account: Freedome doesn't connect

    New User account: Freedome does connect


  • Perelandra
    Perelandra Posts: 4
    Maybe this is why:
    Under the "Security enhancements" section

    Other enhancements

    On multiuser devices, VPNs are now applied per user. This can allow a user to route all network traffic through a VPN without affecting other users on the device. Also, Android now supports FORTIFY_SOURCE level 2, and all code is compiled with those protections. FORTIFY_SOURCE has been enhanced to work with clang

    Does Freedome work with multi-user enabled tablets?
  • Perelandra
    Perelandra Posts: 4


    Thanks for the issue tracker links, looks like KK needs some bug fixes.  I also downloaded SurfEasy VPN and it does the exact same thing, will not connect under the owner account but does connect with a user account.

    Because of this and some other issues with KK I am reverting back to JB.  I like Freedome too much to give it up.

This discussion has been closed.
Product & Pricing Info