Issues with passwordless sftp2 from windows to linux using F-Secure SSH Client

Hi,

I am facing problems whie trying to do a passwordless ssh to Unix box from windows. Public key was generated using F-secure. When the F-secure client attempts it connects without password but when I try to use sftp2 in command line it prompts for password.
 I have tried several options and failed.. no much help in google too.

Any response to possibilities will be much appreciated.

Below is the sftp2 -v output:

 

C:\Documents and Settings\hp-\Desktop>sftp2 -v [email protected]
 SshFileCopy: Making local connection.
 SshFileXferClient: extname [email protected]', data: 00000000: 0d0a .. SshFileXferClient: Negotiated version: 3 (own version: 3, remote version: 3). SshFileCopy: Connection to local, ready to serve requests. Sftp2: Connection ready. SshReadLine: Initializing ReadLine... SshFileCopy: Connecting to remote host. (host = [email protected], user = NULL, port = NULL) Sftp2: Couldn't find ssh2 on path specified (ssh2.exe). Trying default PATH... SshConfig: Unable to open C:/Documents and Settings/hp-/Application Dat a/F-Secure SSH/ssh2_config SshReadLine: Initializing ReadLine... client supports 3 auth methods: 'keyboard-interactive,publickey,password' Ssh2Common: local ip = 10.10.49.141, local port = 2190 Ssh2Common: remote ip = 10.205.50.190, remote port = 22 SshConnection: Wrapping... Remote version: SSH-2.0-ReflectionForSecureIT_7.2.0.115 Ssh2Transport: My version: SSH-1.99-3.2.3 F-Secure SSH Windows Client Ssh2Transport: lang s to c:', lang c to s: `'
 Ssh2Transport: ctos: cipher 3des-cbc, mac hmac-sha1, compression none
 Ssh2Transport: stoc: cipher 3des-cbc, mac hmac-sha1, compression none
 Remote host key found from database.
 Ssh2Common: Received SSHCROSSSTARTUP packet from connection protocol.
 Ssh2Common: Received SSHCROSS_ALGORITHMS packet from connection protocol.
 server offers auth methods 'publickey,keyboard-interactive,password'.
 Ssh2AuthKbdInteractiveClient: Starting kbd-int auth...
 Keyboard-interactive:
 Password:

 

 

Thanks,
 Druva

Best Answer

This discussion has been closed.