F-Secure shows that I have a Rootkit, Whistler.A on an external drive, but it can't remove it.

How can I get rid of a Whistler.A rootkit on an external drive that F-Secure detects, but can't remove.  Should I just leave it alone?


  • Janiashvili
    Janiashvili Posts: 454 Adventurer

    look at action history (Go to Settings, and in 'Virus and spyware scanning' press "view virus and spyware history" link. 

    Thing is, that it might already removed, but as there are more than one engine - one of those engines still thought there is a virus, but as there is not virus it said "cant remove" or something similar.

  • Mackle
    Mackle Posts: 2 New Member

    Dear Janiashvili, I still get a "none" or "failed" response to removal in the history listing.  If it's in the MBR, can I run something like "fix MBR" on this drive to get rid of it?  If I format the drive, will it get the virus out?  Thanks again for your reply.

  • Janiashvili
    Janiashvili Posts: 454 Adventurer

    I just did notice, that it is on external drive.


    find file location and remove manually, i'm not sure rootkits are like basic viruses or how they are, so, please contact support

This discussion has been closed.
Pricing & Product Info