HTC Desire X fails with F-Secure

After installing F-Secure onto my mobile, it worked fine for a while, but now when in applications it will just go to blank screen then return to main screen.

Have turned off most of F-Secure and the phone works fine. Tried asking Virgin Media, but they wiped there hands of it.


Also can not find code to uninstall product.



  • Chrissy
    Chrissy Posts: 406 Active Engager



    Hi!  Sorry for the delay in reply, but I believe your message was in the wrong board, so I've moved it to the Security Board.  Can you confirm which product is giving you the issue, or have you found a way to solve it?


    // Chrissy

  • As stated have just turned V-Secure off. As not getting support from VM and most likely have to be on phone for hours trying to sort this will live with the possibility that my phone could be infected.

    Not happy but that's what you get for going cheap!!
  • Jayson
    Jayson Posts: 490 F-Secure Product Expert



    May I know which version of Android and Mobile Security you have running on this device?


    Please try reinstall the Mobile Security with latest version from your F-Secure SAFE portal.


    Best Regards,

  • As stated in earlier post can not find code to unistall. So updating is not posible.Andriod System is ver. 4.1.1, F-Secure 8.3.13732

  • Jayson
    Jayson Posts: 490 F-Secure Product Expert

    Hi Mario_Capus,


    The latest version 9.1 release should have fix this issue. Kindly contact Technical Support to reset your Security code then logon to F-Secure SAFE or go Google Play to reinstall the product.




    Best Regards,

This discussion has been closed.
Pricing & Product Info